summaryrefslogtreecommitdiffstats
path: root/khexedit/lib/codecs/CMakeLists.txt
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2012-11-10 20:47:02 -0600
committerDarrell Anderson <humanreadable@yahoo.com>2012-11-10 20:47:02 -0600
commitc1a8ee04fbfe9851c1f788bcdcf3a5339ce1e478 (patch)
treeb60bf0191b08974e1ad29fd808d298aaeb29ef5a /khexedit/lib/codecs/CMakeLists.txt
parent42177b2709de3eb2ef8ecde7d2a027fbb05a218c (diff)
downloadtdeutils-c1a8ee04fbfe9851c1f788bcdcf3a5339ce1e478.tar.gz
tdeutils-c1a8ee04fbfe9851c1f788bcdcf3a5339ce1e478.zip
Initial conversion to cmake.
Thanks to Fat-Zer.
Diffstat (limited to 'khexedit/lib/codecs/CMakeLists.txt')
-rw-r--r--khexedit/lib/codecs/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/khexedit/lib/codecs/CMakeLists.txt b/khexedit/lib/codecs/CMakeLists.txt
new file mode 100644
index 0000000..8ef47ad
--- /dev/null
+++ b/khexedit/lib/codecs/CMakeLists.txt
@@ -0,0 +1,35 @@
+#################################################
+#
+# (C) 2012 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/khexedit/lib
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### khecodecs (static) ########################
+
+tde_add_library( khecodecs STATIC_PIC AUTOMOC
+ SOURCES kcharcodec.cpp kbytecodec.cpp
+ ktextcharcodec.cpp kebcdic1047charcodec.cpp
+ kbinarybytecodec.cpp koctalbytecodec.cpp
+ kdecimalbytecodec.cpp
+ khexadecimalbytecodec.cpp
+)
+