summaryrefslogtreecommitdiffstats
path: root/khexedit/parts/kpart/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-22 02:49:40 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-24 15:49:49 +0200
commita1066b66a7b397f1cdac40d6970b9640184fe8f6 (patch)
tree023614a603e30a1f7a3ae99c3bbc366fcb4b2178 /khexedit/parts/kpart/CMakeLists.txt
parent2f27665e4d477b9016dc38bf4d83945a371f9c0d (diff)
downloadtdeutils-a1066b66a7b397f1cdac40d6970b9640184fe8f6.tar.gz
tdeutils-a1066b66a7b397f1cdac40d6970b9640184fe8f6.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 296306a273438f476ab2266d1c03616de1fd5ef7)
Diffstat (limited to 'khexedit/parts/kpart/CMakeLists.txt')
-rw-r--r--khexedit/parts/kpart/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/khexedit/parts/kpart/CMakeLists.txt b/khexedit/parts/kpart/CMakeLists.txt
index 9efb479..11217e4 100644
--- a/khexedit/parts/kpart/CMakeLists.txt
+++ b/khexedit/parts/kpart/CMakeLists.txt
@@ -36,11 +36,12 @@ tde_add_kpart( libkhexedit2part AUTOMOC
##### other data ################################
-install( FILES khexedit2part.desktop
+tde_create_translated_desktop(
+ SOURCE khexedit2part.desktop
DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/khexedit-desktops
)
install( FILES khexedit2partui.rc
DESTINATION ${DATA_INSTALL_DIR}/khexedit2part
)
-