summaryrefslogtreecommitdiffstats
path: root/klaptopdaemon/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-25 12:56:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-25 12:56:52 +0200
commitbf71f730b3e204d4404fbd47562946170bf87de0 (patch)
treebf1b2252d54eb8c1e887e52c1fb17faa16754d1b /klaptopdaemon/CMakeLists.txt
parentc20f6cb658e757b8174be8fb537036bfc3c7c7a8 (diff)
downloadtdeutils-bf71f730b3e204d4404fbd47562946170bf87de0.tar.gz
tdeutils-bf71f730b3e204d4404fbd47562946170bf87de0.zip
klaptopdaemon: Fix acpi helper violation check.
1. Dependence on crcresult.h solved correctly. 2. Used macro tde_add_executable to define makecrc target. 3. Fixed command to run makecrc - it depends on both makecrc and klaptop_acpi_helper, - it must be run in build binary directory, not source, - the target name is used as the makecrc command, so there is no need to use get_target_property( ... LOCATION ), which caused a warning due to CMP0026. 4. The block of code that performs the binary violation verification was rolled back because it was removed in commit 2abe1e6f40 for an unknown reason, and the check was not actually performed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'klaptopdaemon/CMakeLists.txt')
-rw-r--r--klaptopdaemon/CMakeLists.txt33
1 files changed, 16 insertions, 17 deletions
diff --git a/klaptopdaemon/CMakeLists.txt b/klaptopdaemon/CMakeLists.txt
index 2558f04..b7b4d72 100644
--- a/klaptopdaemon/CMakeLists.txt
+++ b/klaptopdaemon/CMakeLists.txt
@@ -60,14 +60,12 @@ tde_add_library( kcmlaptop SHARED AUTOMOC
tde_add_kpart( kcm_laptop AUTOMOC
SOURCES battery.cpp main.cpp pcmcia.cpp
power.cpp warning.cpp acpi.cpp sony.cpp
- profile.cpp buttons.cpp apm.cpp
- ${CMAKE_CURRENT_BINARY_DIR}/crcresult.h
+ profile.cpp buttons.cpp apm.cpp
LINK tdeio-shared kcmlaptop-shared
DESTINATION ${PLUGIN_INSTALL_DIR}
+ DEPENDENCIES crcresult-header
)
-# crcresult.h header is included here cause it is
-# generated during build time. Otherwice the
-# dependency on it won't be handeled correctly.
+
##### kded_klaptopdaemon (kpart) ################
@@ -84,18 +82,19 @@ tde_add_kpart( kded_klaptopdaemon AUTOMOC
##### crcresult.h (header) ######################
-# FIXME: that should potentialy break the cross
-# compilation, If it is possible in
-# generall.
-add_executable( makecrc makecrc.cpp )
-target_link_libraries( makecrc z )
-
-get_target_property( MAKECRC_EXE makecrc LOCATION)
+tde_add_executable( makecrc
+ SOURCES makecrc.cpp
+ LINK z
+)
-add_custom_command( OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/crcresult.h
- COMMAND
- ${MAKECRC_EXE} >${CMAKE_CURRENT_BINARY_DIR}/crcresult.h
- DEPENDS makecrc
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR})
+add_custom_command(
+ OUTPUT crcresult.h
+ COMMAND makecrc > crcresult.h
+ DEPENDS makecrc klaptop_acpi_helper
+)
+add_custom_target( crcresult-header
+ DEPENDS
+ ${CMAKE_CURRENT_BINARY_DIR}/crcresult.h
+)