summaryrefslogtreecommitdiffstats
path: root/klaptopdaemon/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-06-23 01:42:07 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-06-23 01:42:07 +0000
commita2277b6bc715464e83882b90c2a058139b8a6b54 (patch)
treeab09b14014f59b4d8e2ddd12226aa0b22e4dfc5d /klaptopdaemon/Makefile.am
parentd3f79e04b34bd1f70a458b81b28fc8799498c8dc (diff)
downloadtdeutils-a2277b6bc715464e83882b90c2a058139b8a6b54.tar.gz
tdeutils-a2277b6bc715464e83882b90c2a058139b8a6b54.zip
TQt4 port kdeutils
This enables compilation under both Qt3 and Qt4 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeutils@1238125 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'klaptopdaemon/Makefile.am')
-rw-r--r--klaptopdaemon/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/klaptopdaemon/Makefile.am b/klaptopdaemon/Makefile.am
index 8a2e737..a70a155 100644
--- a/klaptopdaemon/Makefile.am
+++ b/klaptopdaemon/Makefile.am
@@ -13,6 +13,7 @@ kded_klaptopdaemon_la_LDFLAGS = $(all_libraries) -module -avoid-version -lXtst
kded_klaptopdaemon_la_LIBADD = $(LIB_KDEUI) $(LIB_XSS) libkcmlaptop.la
klaptop_acpi_helper_SOURCES = acpi_helper.cpp
+klaptop_acpi_helper_LDADD = $(LIB_QT)
klaptop_check_SOURCES = laptop_check.cpp
klaptop_check_LDFLAGS = $(all_libraries)
@@ -41,7 +42,7 @@ dummy.cpp:
noinst_PROGRAMS = makecrc
makecrc_SOURCES = makecrc.cpp
-makecrc_LDADD = $(LIBZ)
+makecrc_LDADD = $(LIBZ) $(LIB_QT)
crcresult.h: makecrc klaptop_acpi_helper
./makecrc >crcresult.h