summaryrefslogtreecommitdiffstats
path: root/kregexpeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-22 02:49:40 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-22 02:49:40 +0200
commit296306a273438f476ab2266d1c03616de1fd5ef7 (patch)
tree7788ff1608858031d0b9816452591f2c62f42bc0 /kregexpeditor/CMakeLists.txt
parent5422ccd94be4a116b9334fb3b350c3a07ff7505e (diff)
downloadtdeutils-296306a273438f476ab2266d1c03616de1fd5ef7.tar.gz
tdeutils-296306a273438f476ab2266d1c03616de1fd5ef7.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kregexpeditor/CMakeLists.txt')
-rw-r--r--kregexpeditor/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/kregexpeditor/CMakeLists.txt b/kregexpeditor/CMakeLists.txt
index edc9fd1..a6aea36 100644
--- a/kregexpeditor/CMakeLists.txt
+++ b/kregexpeditor/CMakeLists.txt
@@ -100,11 +100,13 @@ tde_install_icons( )
##### other data ################################
-install( FILES kregexpeditor.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR}
+tde_create_translated_desktop(
+ SOURCE kregexpeditor.desktop
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kregexpeditor-desktops
)
-install( FILES kregexpeditorgui.desktop
+tde_create_translated_desktop(
+ SOURCE kregexpeditorgui.desktop
DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kregexpeditor-desktops
)
-