summaryrefslogtreecommitdiffstats
path: root/ksim/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-22 02:49:40 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-22 02:49:40 +0200
commit296306a273438f476ab2266d1c03616de1fd5ef7 (patch)
tree7788ff1608858031d0b9816452591f2c62f42bc0 /ksim/CMakeLists.txt
parent5422ccd94be4a116b9334fb3b350c3a07ff7505e (diff)
downloadtdeutils-296306a273438f476ab2266d1c03616de1fd5ef7.tar.gz
tdeutils-296306a273438f476ab2266d1c03616de1fd5ef7.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ksim/CMakeLists.txt')
-rw-r--r--ksim/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/ksim/CMakeLists.txt b/ksim/CMakeLists.txt
index 59037f7..20fc59e 100644
--- a/ksim/CMakeLists.txt
+++ b/ksim/CMakeLists.txt
@@ -50,12 +50,12 @@ tde_add_kpart( ksim_panelextension AUTOMOC
##### other data ################################
-install( FILES ksim.desktop
- DESTINATION
- ${DATA_INSTALL_DIR}/kicker/extensions
+tde_create_translated_desktop(
+ SOURCE ksim.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kicker/extensions
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/ksim-desktops
)
install( FILES ksim_panelextensionrc
DESTINATION ${CONFIG_INSTALL_DIR}
)
-