summaryrefslogtreecommitdiffstats
path: root/ksim/library/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit2bda8f7717adf28da4af0d34fb82f63d2868c31d (patch)
tree8d927b7b47a90c4adb646482a52613f58acd6f8c /ksim/library/Makefile.am
downloadtdeutils-2bda8f7717adf28da4af0d34fb82f63d2868c31d.tar.gz
tdeutils-2bda8f7717adf28da4af0d34fb82f63d2868c31d.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeutils@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'ksim/library/Makefile.am')
-rw-r--r--ksim/library/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/ksim/library/Makefile.am b/ksim/library/Makefile.am
new file mode 100644
index 0000000..f3b834f
--- /dev/null
+++ b/ksim/library/Makefile.am
@@ -0,0 +1,25 @@
+lib_LTLIBRARIES = libksimcore.la
+
+libksimcore_la_SOURCES = common.cpp themeloader.cpp \
+ chart.cpp label.cpp \
+ led.cpp progress.cpp \
+ pluginglobal.cpp pluginloader.cpp \
+ pluginmodule.cpp ksimconfig.cpp
+
+libksimcore_la_LDFLAGS = $(all_libraries) -version-info 1:0 -no-undefined
+libksimcore_la_LIBADD = $(LIB_KDEUI)
+
+ksiminclude_HEADERS = common.h themeloader.h \
+ chart.h label.h \
+ led.h progress.h \
+ pluginglobal.h pluginloader.h \
+ pluginmodule.h themetypes.h \
+ ksimconfig.h
+
+
+ksimincludedir = $(includedir)/ksim
+
+INCLUDES= $(all_includes)
+
+METASOURCES = AUTO
+