summaryrefslogtreecommitdiffstats
path: root/kwallet/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit2bda8f7717adf28da4af0d34fb82f63d2868c31d (patch)
tree8d927b7b47a90c4adb646482a52613f58acd6f8c /kwallet/Makefile.am
downloadtdeutils-2bda8f7717adf28da4af0d34fb82f63d2868c31d.tar.gz
tdeutils-2bda8f7717adf28da4af0d34fb82f63d2868c31d.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeutils@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kwallet/Makefile.am')
-rw-r--r--kwallet/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/kwallet/Makefile.am b/kwallet/Makefile.am
new file mode 100644
index 0000000..5c5fe28
--- /dev/null
+++ b/kwallet/Makefile.am
@@ -0,0 +1,26 @@
+INCLUDES= $(all_includes)
+
+SUBDIRS=. icons konfigurator
+
+bin_PROGRAMS = kwalletmanager
+kwalletmanager_SOURCES = walletwidget.ui kwalletmanager.cpp \
+ kwalletmanager.skel main.cpp kwalletpopup.cpp \
+ kwalleteditor.cpp kwmapeditor.cpp allyourbase.cpp \
+ kbetterthankdialogbase.ui
+kwalletmanager_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kwalletmanager_LDADD = $(LIB_KIO) -lkwalletclient
+METASOURCES = AUTO
+noinst_HEADERS = kwalletmanager.h kwalletpopup.h walletwidget.h kwalleteditor.h\
+ allyourbase.h kwmapeditor.h
+
+xdg_apps_DATA = kwalletmanager.desktop kwalletmanager-kwalletd.desktop
+
+KDE_ICON = kwalletmanager
+
+rc_DATA = kwalletmanager.rc kwalleteditor.rc
+rcdir = $(kde_datadir)/kwalletmanager
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kwalletmanager.pot
+
+kbetterthankdialogbase.lo: kbetterthankdialogbase.ui kbetterthankdialogbase.ui.h