summaryrefslogtreecommitdiffstats
path: root/tdefilereplace/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-22 02:49:40 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-22 02:49:40 +0200
commit296306a273438f476ab2266d1c03616de1fd5ef7 (patch)
tree7788ff1608858031d0b9816452591f2c62f42bc0 /tdefilereplace/CMakeLists.txt
parent5422ccd94be4a116b9334fb3b350c3a07ff7505e (diff)
downloadtdeutils-296306a273438f476ab2266d1c03616de1fd5ef7.tar.gz
tdeutils-296306a273438f476ab2266d1c03616de1fd5ef7.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdefilereplace/CMakeLists.txt')
-rw-r--r--tdefilereplace/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/tdefilereplace/CMakeLists.txt b/tdefilereplace/CMakeLists.txt
index 621c0e0..15c70a1 100644
--- a/tdefilereplace/CMakeLists.txt
+++ b/tdefilereplace/CMakeLists.txt
@@ -26,8 +26,15 @@ link_directories(
##### other data ################################
tde_install_icons( )
-install( FILES tdefilereplace.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES tdefilereplacepart.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE tdefilereplace.desktop
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdefilereplace-desktops
+)
+tde_create_translated_desktop(
+ SOURCE tdefilereplacepart.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdefilereplace-desktops
+)
install( FILES tdefilereplacepartui.rc DESTINATION ${DATA_INSTALL_DIR}/tdefilereplacepart )
install( FILES tdefilereplaceui.rc DESTINATION ${DATA_INSTALL_DIR}/tdefilereplace )