summaryrefslogtreecommitdiffstats
path: root/tdelirc/kcmlirc/Makefile.am
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2013-05-17 12:45:40 -0500
committerDarrell Anderson <humanreadable@yahoo.com>2013-05-17 12:45:40 -0500
commit359294c33620c8328d61f67635046d7cc060530c (patch)
treef2ac08fdad8860f7bc1ac76203e31013a799fda7 /tdelirc/kcmlirc/Makefile.am
parent7be7990fc5770d2cbcd937772e8239167b5900c6 (diff)
downloadtdeutils-359294c33620c8328d61f67635046d7cc060530c.tar.gz
tdeutils-359294c33620c8328d61f67635046d7cc060530c.zip
Rename kdessh -> tdessh and kdelirc -> tdelirc.
Diffstat (limited to 'tdelirc/kcmlirc/Makefile.am')
-rw-r--r--tdelirc/kcmlirc/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tdelirc/kcmlirc/Makefile.am b/tdelirc/kcmlirc/Makefile.am
new file mode 100644
index 0000000..53eb7af
--- /dev/null
+++ b/tdelirc/kcmlirc/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = -I../irkick -I$(srcdir)/../irkick -I$(srcdir)/../tdelirc $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = kcm_kcmlirc.la
+
+noinst_HEADERS = kcmlirc.h addaction.h addactionbase.h
+kcm_kcmlirc_la_SOURCES = selectprofile.ui newmode.ui kcmlircbase.ui kcmlirc.cpp addactionbase.ui addaction.cpp kcmlirc.skel editactionbase.ui editmodebase.ui editmode.cpp editaction.cpp modeslist.cpp
+kcm_kcmlirc_la_LIBADD = $(LIB_TDEUI) $(LIB_TDEFILE) ../tdelirc/libtdelirc.la
+kcm_kcmlirc_la_LDFLAGS = -module -avoid-version $(all_libraries) -no-undefined
+
+xdg_apps_DATA = kcmlirc.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/kcmlirc.pot