summaryrefslogtreecommitdiffstats
path: root/kcalc/knumber/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kcalc/knumber/CMakeLists.txt')
-rw-r--r--kcalc/knumber/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/kcalc/knumber/CMakeLists.txt b/kcalc/knumber/CMakeLists.txt
new file mode 100644
index 0000000..91cce06
--- /dev/null
+++ b/kcalc/knumber/CMakeLists.txt
@@ -0,0 +1,39 @@
+#################################################
+#
+# (C) 2012 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+# FIXME: add optional testing support
+# add_subdirectory( tests )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+add_definitions(
+ -D_GNU_SOURCE
+ -D_ISOC99_SOURCE
+)
+
+
+##### knumber (static) ##########################
+
+tde_add_library( knumber STATIC_PIC
+ SOURCES knumber.cpp knumber_priv.cpp
+ LINK ${GMP_LIBRARY}
+)
+