summaryrefslogtreecommitdiffstats
path: root/kregexpeditor/test-without-dl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kregexpeditor/test-without-dl/CMakeLists.txt')
-rw-r--r--kregexpeditor/test-without-dl/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/kregexpeditor/test-without-dl/CMakeLists.txt b/kregexpeditor/test-without-dl/CMakeLists.txt
new file mode 100644
index 0000000..82fed32
--- /dev/null
+++ b/kregexpeditor/test-without-dl/CMakeLists.txt
@@ -0,0 +1,36 @@
+#################################################
+#
+# (C) 2012 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${CMAKE_BINARY_DIR}/kregexpeditor
+)
+
+
+##### regexptest (test) #########################
+
+tde_add_executable( regexptest AUTOMOC
+ SOURCES main.cpp
+ DESTINATION ${BIN_INSTALL_DIR}
+ LINK tdeui-shared kregexpeditorcommon-shared
+)
+
+add_test( NAME regexptest-test
+ COMMAND regexptest)
+