summaryrefslogtreecommitdiffstats
path: root/languages/php/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit114a878c64ce6f8223cfd22d76a20eb16d177e5e (patch)
treeacaf47eb0fa12142d3896416a69e74cbf5a72242 /languages/php/Makefile.am
downloadtdevelop-114a878c64ce6f8223cfd22d76a20eb16d177e5e.tar.gz
tdevelop-114a878c64ce6f8223cfd22d76a20eb16d177e5e.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdevelop@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'languages/php/Makefile.am')
-rw-r--r--languages/php/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/languages/php/Makefile.am b/languages/php/Makefile.am
new file mode 100644
index 00000000..ac053aaf
--- /dev/null
+++ b/languages/php/Makefile.am
@@ -0,0 +1,24 @@
+# Here resides the PHP support part.
+
+INCLUDES = -I$(top_srcdir)/lib/interfaces \
+ -I$(top_srcdir)/lib/interfaces/extensions -I$(top_srcdir)/lib/interfaces/external -I$(top_srcdir)/lib/util \
+ -I$(top_srcdir)/lib/widgets $(all_includes)
+SUBDIRS = data app_templates file_templates doc
+
+
+kde_module_LTLIBRARIES = libkdevphpsupport.la
+libkdevphpsupport_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkdevphpsupport_la_LIBADD = $(top_builddir)/lib/libkdevelop.la $(top_builddir)/lib/widgets/libkdevwidgets.la $(LIB_KHTML)
+
+libkdevphpsupport_la_SOURCES = phpsupportpart.cpp phpconfigwidgetbase.ui phpconfigwidget.cpp phpinfodlg.ui phphtmlview.cpp phperrorview.cpp phpconfigdata.cpp phpcodecompletion.cpp phpparser.cpp phpnewclassdlgbase.ui phpnewclassdlg.cpp phpfile.cpp
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = kdevphpsupport.desktop
+
+rcdir = $(kde_datadir)/kdevphpsupport
+rc_DATA = kdevphpsupport.rc
+
+templatedir = ${kde_datadir}/kdevabbrev/templates
+template_DATA = phptemplates