summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit114a878c64ce6f8223cfd22d76a20eb16d177e5e (patch)
treeacaf47eb0fa12142d3896416a69e74cbf5a72242 /lib/Makefile.am
downloadtdevelop-114a878c64ce6f8223cfd22d76a20eb16d177e5e.tar.gz
tdevelop-114a878c64ce6f8223cfd22d76a20eb16d177e5e.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdevelop@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 00000000..e75b5d04
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,23 @@
+# Here resides the library of general KDevelop-related utilities,
+# which may be linked by any plugin or part. This is installed
+# as a shared library, including header files
+
+INCLUDES = $(all_includes)
+
+lib_LTLIBRARIES = libkdevelop.la
+libkdevelop_la_LDFLAGS = -no-undefined $(all_libraries) -version-info 1:0
+libkdevelop_la_LIBADD = $(top_builddir)/lib/interfaces/libkdevinterfaces.la \
+ $(top_builddir)/lib/widgets/propeditor/libkdevpropertyeditor.la $(LIB_KIO)
+
+# $(top_builddir)/lib/util/libkdevutil.la $(top_builddir)/lib/widgets/propeditor/libkdevpropertyeditor.la \
+# $(top_builddir)/lib/interfaces/external/libkinterfacedesigner.la $(top_builddir)/lib/interfaces/extensions/libkdevextensions.la \
+# -lktexteditor $(LIB_KPARTS) $(LIB_KIO) -lkscript
+libkdevelop_la_SOURCES = dummy.cpp
+
+
+
+SUBDIRS = util interfaces widgets antlr catalog \
+ cppparser astyle
+
+DOXYGEN_EMPTY = YES
+include ../Doxyfile.am