summaryrefslogtreecommitdiffstats
path: root/src/newui/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-11-17 16:06:35 +0100
committerSlávek Banko <slavek.banko@axis.cz>2012-11-17 18:35:42 +0100
commitfd907e533d5ae62daa846aefbdb6d3c27fcb0b2c (patch)
treee3296be6dbbd1505bcdcd13aafc23a43fbbe6c97 /src/newui/CMakeLists.txt
parent466b6fc982f27dcc39986e30d516a2a173879af7 (diff)
downloadtdevelop-fd907e533d5ae62daa846aefbdb6d3c27fcb0b2c.tar.gz
tdevelop-fd907e533d5ae62daa846aefbdb6d3c27fcb0b2c.zip
Fix various cmake build issues
(cherry picked from commit 96f0726b226f4b404c38f998fbdd02cf728ba6e8)
Diffstat (limited to 'src/newui/CMakeLists.txt')
-rw-r--r--src/newui/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/newui/CMakeLists.txt b/src/newui/CMakeLists.txt
index b65bff6a..5b892480 100644
--- a/src/newui/CMakeLists.txt
+++ b/src/newui/CMakeLists.txt
@@ -16,10 +16,13 @@ include_directories(
)
-##### d (static) ################################
+##### d (shared) ################################
-tde_add_library( d STATIC_PIC AUTOMOC
+tde_add_library( d SHARED AUTOMOC
SOURCES
dmainwindow.cpp buttonbar.cpp button.cpp ddockwindow.cpp
docksplitter.cpp dtabwidget.cpp
+ LINK kparts-shared kdecore-shared kdeui-shared
+ VERSION 0.0.0
+ DESTINATION ${LIB_INSTALL_DIR}
)