summaryrefslogtreecommitdiffstats
path: root/vcs/subversion/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-29 22:43:34 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-30 16:00:07 +0200
commitfe44776673b28ca94338f23d8e7ac71593fa88ba (patch)
treeb900146c853acbd44900bfb77a35a1af3c77aa5d /vcs/subversion/CMakeLists.txt
parentc0b663c4c873df495743600b8f703744420eddfa (diff)
downloadtdevelop-fe44776673b28ca94338f23d8e7ac71593fa88ba.tar.gz
tdevelop-fe44776673b28ca94338f23d8e7ac71593fa88ba.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'vcs/subversion/CMakeLists.txt')
-rw-r--r--vcs/subversion/CMakeLists.txt15
1 files changed, 10 insertions, 5 deletions
diff --git a/vcs/subversion/CMakeLists.txt b/vcs/subversion/CMakeLists.txt
index fb51fe3d..87fdf293 100644
--- a/vcs/subversion/CMakeLists.txt
+++ b/vcs/subversion/CMakeLists.txt
@@ -30,15 +30,20 @@ link_directories(
##### other data ################################
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
kdevsubversion.desktop kdevsvn+file.protocol
kdevsvn+http.protocol kdevsvn+https.protocol
kdevsvn+ssh.protocol kdevsvn+svn.protocol
- DESTINATION ${SERVICES_INSTALL_DIR} )
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR tdevelop-desktops
+)
-install( FILES
- kdevsvnd.desktop
- DESTINATION ${SERVICES_INSTALL_DIR}/kded )
+tde_create_translated_desktop(
+ SOURCE kdevsvnd.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/kded
+ PO_DIR tdevelop-desktops
+)
##### libkdevsubversion (module) ################