summaryrefslogtreecommitdiffstats
path: root/languages/perl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'languages/perl/Makefile.am')
-rw-r--r--languages/perl/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/languages/perl/Makefile.am b/languages/perl/Makefile.am
new file mode 100644
index 00000000..2354c124
--- /dev/null
+++ b/languages/perl/Makefile.am
@@ -0,0 +1,25 @@
+# Here resides the Perl support part.
+
+INCLUDES = -I$(top_srcdir)/lib/interfaces \
+ -I$(top_srcdir)/lib/interfaces/extensions -I$(top_srcdir)/lib/interfaces/external -I$(top_srcdir)/lib/util \
+ $(all_includes)
+SUBDIRS = app_templates file_templates doc
+
+
+kde_module_LTLIBRARIES = libkdevperlsupport.la kio_perldoc.la
+libkdevperlsupport_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkdevperlsupport_la_LIBADD = $(top_builddir)/lib/libkdevelop.la
+
+libkdevperlsupport_la_SOURCES = perlparser.cpp perlsupportpart.cpp perlconfigwidget.cpp perlconfigwidgetbase.ui
+
+kio_perldoc_la_SOURCES = perldoc.cpp
+kio_perldoc_la_LIBADD = $(LIB_KIO)
+kio_perldoc_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = kdevperlsupport.desktop perldoc.protocol
+
+rcdir = $(kde_datadir)/kdevperlsupport
+rc_DATA = kdevperlsupport.rc