summaryrefslogtreecommitdiffstats
path: root/languages/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'languages/python/Makefile.am')
-rw-r--r--languages/python/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/languages/python/Makefile.am b/languages/python/Makefile.am
new file mode 100644
index 00000000..ddebc35d
--- /dev/null
+++ b/languages/python/Makefile.am
@@ -0,0 +1,31 @@
+# Here resides the Python support part.
+# Do not confuse this with the python part responsible for KDevelop scripting
+
+INCLUDES = -I$(top_srcdir)/lib/interfaces -I$(top_srcdir)/languages/lib/designer_integration \
+ -I$(top_srcdir)/lib/interfaces/extensions -I$(top_srcdir)/lib/interfaces/external -I$(top_srcdir)/lib/util -I$(top_builddir)/languages/lib/designer_integration \
+ $(all_includes)
+SUBDIRS = app_templates file_templates doc
+
+
+kde_module_LTLIBRARIES = libkdevpythonsupport.la kio_pydoc.la
+
+libkdevpythonsupport_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkdevpythonsupport_la_LIBADD = $(top_builddir)/lib/libkdevelop.la \
+ $(top_builddir)/languages/lib/designer_integration/libdesignerintegration.la
+libkdevpythonsupport_la_SOURCES = pythonsupportpart.cpp pythonconfigwidget.cpp pythonconfigwidgetbase.ui \
+ pythonimplementationwidget.cpp qtdesignerpythonintegration.cpp
+
+kio_pydoc_la_SOURCES = pydoc.cpp
+kio_pydoc_la_LIBADD = $(LIB_KIO)
+kio_pydoc_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+METASOURCES = AUTO
+
+slavedir = $(kde_datadir)/kio_pydoc
+slave_DATA = kde_pydoc.py
+
+servicedir = $(kde_servicesdir)
+service_DATA = kdevpythonsupport.desktop pydoc.protocol
+
+rcdir = $(kde_datadir)/kdevpythonsupport
+rc_DATA = kdevpythonsupport.rc