summaryrefslogtreecommitdiffstats
path: root/src/newui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/newui/CMakeLists.txt')
-rw-r--r--src/newui/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/newui/CMakeLists.txt b/src/newui/CMakeLists.txt
index b65bff6a..5b892480 100644
--- a/src/newui/CMakeLists.txt
+++ b/src/newui/CMakeLists.txt
@@ -16,10 +16,13 @@ include_directories(
)
-##### d (static) ################################
+##### d (shared) ################################
-tde_add_library( d STATIC_PIC AUTOMOC
+tde_add_library( d SHARED AUTOMOC
SOURCES
dmainwindow.cpp buttonbar.cpp button.cpp ddockwindow.cpp
docksplitter.cpp dtabwidget.cpp
+ LINK kparts-shared kdecore-shared kdeui-shared
+ VERSION 0.0.0
+ DESTINATION ${LIB_INSTALL_DIR}
)