summaryrefslogtreecommitdiffstats
path: root/vcs/perforce/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vcs/perforce/Makefile.am')
-rw-r--r--vcs/perforce/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/vcs/perforce/Makefile.am b/vcs/perforce/Makefile.am
new file mode 100644
index 00000000..e684e2f0
--- /dev/null
+++ b/vcs/perforce/Makefile.am
@@ -0,0 +1,19 @@
+# Here resides the cvs part
+
+INCLUDES = -I$(top_srcdir)/lib/interfaces \
+ -I$(top_srcdir)/lib/interfaces/extensions -I$(top_srcdir)/lib/util $(all_includes)
+
+kde_module_LTLIBRARIES = libkdevperforce.la
+libkdevperforce_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkdevperforce_la_LIBADD = $(top_builddir)/lib/libkdevelop.la $(top_builddir)/lib/interfaces/extensions/libkdevextensions.la
+
+libkdevperforce_la_SOURCES = perforcepart.cpp commitdlg.cpp
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = kdevperforce.desktop
+
+rcdir = $(kde_datadir)/kdevperforce
+
+SUBDIRS = integrator