summaryrefslogtreecommitdiffstats
path: root/kimagemapeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-06-28 15:14:51 +0200
committergregory guy <gregory-tde@laposte.net>2021-03-11 15:04:14 +0100
commit4c43d1fbb66a296958ed1d0dbddf3f8ac4466130 (patch)
treee532b01e8168b2f849f8aaa3266a58b088705726 /kimagemapeditor/CMakeLists.txt
parent10d21d001e92e653cec6b6d1c05983abd00a1195 (diff)
downloadtdewebdev-4c43d1fbb66a296958ed1d0dbddf3f8ac4466130.tar.gz
tdewebdev-4c43d1fbb66a296958ed1d0dbddf3f8ac4466130.zip
Conversion to the cmake building system.
Delete empty files (dummy.cpp, xsldbgconfig.h). Remove hard-coded path for the kmdr-executor executable. Replaced $TQTDIR/doc/html string path for TQTDOCDIR in kommander. Add man pages taken from the Debian packaging. Signed-off-by: gregory guy <gregory-tde@laposte.net> Fix linking - kxsldbgcommon-static and kimagemapeditorcommon-static needs to be embedded. Move the linking of xml and readline libraries to the appropriate static libraries. Add build option WITH_QUANTA_CVSSERVICE. Add a test whether the readline can be linked standalone or whether ncurses is needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kimagemapeditor/CMakeLists.txt')
-rw-r--r--kimagemapeditor/CMakeLists.txt83
1 files changed, 83 insertions, 0 deletions
diff --git a/kimagemapeditor/CMakeLists.txt b/kimagemapeditor/CMakeLists.txt
new file mode 100644
index 00000000..78bfb22f
--- /dev/null
+++ b/kimagemapeditor/CMakeLists.txt
@@ -0,0 +1,83 @@
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kimagemapeditorcommon (static)
+
+tde_add_library( kimagemapeditorcommon STATIC_PIC AUTOMOC
+
+ SOURCES
+ qextfileinfo.cpp
+ areacreator.cpp
+ kimearea.cpp
+ kimecommands.cpp
+ kimedialogs.cpp
+ kimagemapeditor.cpp
+ drawzone.cpp
+ arealistview.cpp
+ imageslistview.cpp
+ mapslistview.cpp
+)
+
+
+##### libkimagemapeditor (kpart)
+
+configure_file( ${TDE_CMAKE_TEMPLATES}/tde_dummy_cpp.cmake dummy.cpp COPYONLY )
+
+tde_add_kpart( libkimagemapeditor AUTOMOC
+
+ SOURCES
+ dummy.cpp
+ EMBED
+ kimagemapeditorcommon-static
+ LINK
+ tdeparts-shared
+ tdehtml-shared
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### kimagemapeditor (executable)
+
+tde_add_executable( kimagemapeditor AUTOMOC
+
+ SOURCES
+ main.cpp
+ kimeshell.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+ tdehtml-shared
+ kimagemapeditorcommon-static
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES kimagemapeditorui.rc kimagemapeditorpartui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kimagemapeditor
+)
+
+tde_create_translated_desktop( kimagemapeditor.desktop )
+
+tde_create_translated_desktop(
+ SOURCE kimagemapeditorpart.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)