summaryrefslogtreecommitdiffstats
path: root/kommander/plugin/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commite9ae80694875f869892f13f4fcaf1170a00dea41 (patch)
treeaa2f8d8a217e2d376224c8d46b7397b68d35de2d /kommander/plugin/Makefile.am
downloadtdewebdev-e9ae80694875f869892f13f4fcaf1170a00dea41.tar.gz
tdewebdev-e9ae80694875f869892f13f4fcaf1170a00dea41.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdewebdev@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kommander/plugin/Makefile.am')
-rw-r--r--kommander/plugin/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kommander/plugin/Makefile.am b/kommander/plugin/Makefile.am
new file mode 100644
index 00000000..be1bb9f4
--- /dev/null
+++ b/kommander/plugin/Makefile.am
@@ -0,0 +1,17 @@
+lib_LTLIBRARIES = libkommanderplugin.la
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(top_srcdir)/kommander/widget $(all_includes)
+
+# the library search path.
+libkommanderplugin_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) -no-undefined
+
+# the libraries to link against.
+libkommanderplugin_la_LIBADD = $(LIB_KDEUI) $(LIB_QT)
+
+libkommanderplugin_la_SOURCES = kommanderplugin.cpp specialinformation.cpp
+
+include_HEADERS = kommanderplugin.h specials.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO