summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-10 02:20:37 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-10 02:20:37 +0000
commit215dff23960d6691b85f8417b2695b0a911fa3a1 (patch)
treef89f485e5f991b11f25a266236e7de62fb86e200 /src/Makefile.am
downloadtdmtheme-215dff23960d6691b85f8417b2695b0a911fa3a1.tar.gz
tdmtheme-215dff23960d6691b85f8417b2695b0a911fa3a1.zip
Added KDE3 KDM themer application
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kdmtheme@1088046 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..94379de
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = kcm_kdmtheme.la
+
+kcm_kdmtheme_la_SOURCES = kdmtheme.cpp
+kcm_kdmtheme_la_LIBADD = -lkio -lknewstuff $(LIB_KDEUI)
+kcm_kdmtheme_la_LDFLAGS = -avoid-version -module -no-undefined $(all_libraries)
+
+
+xdg_apps_DATA = kdmtheme.desktop
+
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmkdmtheme.pot