summaryrefslogtreecommitdiffstats
path: root/src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-10-20 14:40:51 +0200
committergregory guy <gregory-tde@laposte.net>2021-01-13 18:12:31 +0100
commit81b64bcfc0a32fdeb0e4f367adbf273d924e55f4 (patch)
tree9e0903eb2b5cc19a7dcf4874d098a29133d3163c /src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt
parent8b4f72aa0753110a46db9195216f3c88e14a9b69 (diff)
downloadtork-81b64bcfc0a32fdeb0e4f367adbf273d924e55f4.tar.gz
tork-81b64bcfc0a32fdeb0e4f367adbf273d924e55f4.zip
Conversion to the cmake building system.
Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt')
-rw-r--r--src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt b/src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt
new file mode 100644
index 0000000..a0b9be0
--- /dev/null
+++ b/src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt
@@ -0,0 +1,23 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/src
+ ${ZLIB_INCLUDE_DIRS}
+)
+
+
+##### geoip (static)
+
+tde_add_library( geoip STATIC_PIC
+
+ SOURCES
+ GeoIP.c
+ GeoIPCity.c
+ regionName.c
+ timeZone.c
+ GeoIPUpdate.c
+ md5.c
+ LINK
+ ${ZLIB_LIBRARIES}
+)