summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-12-06 15:28:04 +0100
committerSlávek Banko <slavek.banko@axis.cz>2021-12-08 16:28:12 +0100
commit379367890cb9cc9721234b6b810a94ecec388b75 (patch)
treefad11c7b9f8432a7e1815399cc847c3ea6b4cd2d /CMakeLists.txt
parentbf076238d30b3e8523b5362f5698ea2e3660c5bf (diff)
downloadtqscintilla-379367890cb9cc9721234b6b810a94ecec388b75.tar.gz
tqscintilla-379367890cb9cc9721234b6b810a94ecec388b75.zip
cmake: Install the library to the default system location.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 1382f3ddb7d28b59432c8c32455734bada2b6016)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 89273b7..cd4c56f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,6 +25,7 @@ include( CheckIncludeFile )
include( CheckLibraryExists )
include( CheckCSourceCompiles )
include( CheckCXXSourceCompiles )
+include( GNUInstallDirs OPTIONAL )
#### include our cmake modules
@@ -35,6 +36,9 @@ include( TDEMacros )
##### setup install paths
+if( CMAKE_INSTALL_LIBDIR )
+ tde_setup_install_path( LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}" )
+endif()
include( TDESetupPaths )
tde_setup_paths( )