summaryrefslogtreecommitdiffstats
path: root/designer/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2021-10-07 15:17:57 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-12-08 16:28:04 +0100
commitbf076238d30b3e8523b5362f5698ea2e3660c5bf (patch)
treef9651b26933ef3054a482f07ae428fd5c0aec431 /designer/CMakeLists.txt
parent8081a13a660196b987f3e99f899f502f9bc947c7 (diff)
downloadtqscintilla-bf076238d30b3e8523b5362f5698ea2e3660c5bf.tar.gz
tqscintilla-bf076238d30b3e8523b5362f5698ea2e3660c5bf.zip
Conversion to the cmake building system.
Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit a69b55c674b0528c00598bea54b7a661f4e49f27)
Diffstat (limited to 'designer/CMakeLists.txt')
-rw-r--r--designer/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/designer/CMakeLists.txt b/designer/CMakeLists.txt
new file mode 100644
index 0000000..91cb885
--- /dev/null
+++ b/designer/CMakeLists.txt
@@ -0,0 +1,24 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/qt
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### qscintillaplugin (shared)
+
+tde_add_library( qscintillaplugin SHARED
+
+ SOURCES
+ qscintillaplugin.cpp
+ LINK
+ qscintilla-shared
+
+ DESTINATION ${TQT_PLUGINS_DIR}/designer
+)