summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2024-03-05 15:21:25 +0300
committerAlexander Golubev <fatzer2@gmail.com>2024-03-08 14:50:56 +0300
commit7801f68701a8673fdeaeca3935af9033a33fbe93 (patch)
treec3db6a01333cfcff8f394bdc992a8ea72a4b8e9d /CMakeLists.txt
parentbdacb0d141053484cd70d90434c48fd4fee15af5 (diff)
downloadtqt3-7801f68701a8673fdeaeca3935af9033a33fbe93.tar.gz
tqt3-7801f68701a8673fdeaeca3935af9033a33fbe93.zip
cmake: build sql drivers as plugins
Signed-off-by: Alexander Golubev <fatzer2@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c4c76062..67e6c3d08 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -121,7 +121,7 @@ option( WITH_MODULE_STYLES "Build the styles module" ${WITH_MODULE_AL
option( WITH_MODULE_SQL "Build the SQL module" ${WITH_MODULE_ALL} )
-##### user requested styles:
+##### user requested styles
option( BUILD_STYLE_PLUGIN_ALL "Build all styles as plugins" OFF )
option( BUILD_STYLE_PLUGIN_MOTIF "Build Motif style as plugin" ${BUILD_STYLE_PLUGIN_ALL} )
@@ -150,7 +150,7 @@ option( WITH_STYLE_INTERLACE "Build interlace style" OFF )
##### user requested sql modules
-option( BUILD_SQL_PLUGIN_ALL "Build all sql plugins" ${WITH_MODULE_SQL} )
+option( BUILD_SQL_PLUGIN_ALL "Build all sql plugins" OFF )
option( BUILD_SQL_PLUGIN_PSQL "Build plugin for PostgreSQL" ${BUILD_SQL_PLUGIN_ALL} )
option( BUILD_SQL_PLUGIN_MYSQL "Build plugin for MySQL" ${BUILD_SQL_PLUGIN_ALL} )
option( BUILD_SQL_PLUGIN_ODBC "Build plugin for ODBC" ${BUILD_SQL_PLUGIN_ALL} )
@@ -159,7 +159,7 @@ option( BUILD_SQL_PLUGIN_IBASE "Build plugin for Firebird" ${BUILD_SQL_PLUGI
option( BUILD_SQL_PLUGIN_SQLITE3 "Build plugin for SQLite3" ${BUILD_SQL_PLUGIN_ALL} )
-option( WITH_SQL_DRIVER_ALL "Build all sql drivers" OFF )
+option( WITH_SQL_DRIVER_ALL "Build all sql drivers" ${WITH_ALL_OPTIONS} )
option( WITH_SQL_DRIVER_PSQL "Build support for PostgreSQL" ${WITH_SQL_DRIVER_ALL} )
option( WITH_SQL_DRIVER_MYSQL "Build support for MySQL" ${WITH_SQL_DRIVER_ALL} )
option( WITH_SQL_DRIVER_ODBC "Build support for ODBC" ${WITH_SQL_DRIVER_ALL} )