summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2024-03-05 14:14:43 +0300
committerAlexander Golubev <fatzer2@gmail.com>2024-03-08 14:50:56 +0300
commitbdacb0d141053484cd70d90434c48fd4fee15af5 (patch)
tree286c696cb3d31380c61f0d500a8c6d0467e7f756 /CMakeLists.txt
parentbf48334d3d4845b15775d39ba05f4a85293c1d5d (diff)
downloadtqt3-bdacb0d141053484cd70d90434c48fd4fee15af5.tar.gz
tqt3-bdacb0d141053484cd70d90434c48fd4fee15af5.zip
cmake: add options to build styles as plugins
Signed-off-by: Alexander Golubev <fatzer2@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 19 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8e8cfdbd..0c4c76062 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -123,16 +123,27 @@ option( WITH_MODULE_SQL "Build the SQL module" ${WITH_MODULE_AL
##### user requested styles:
-option( WITH_STYLE_ALL "Build all style" ${WITH_MODULE_STYLES} )
-option( WITH_STYLE_MOTIF "Build Motif style" ${WITH_STYLES_ALL} )
-option( WITH_STYLE_WINDOWS "Build Windows style" ${WITH_STYLES_ALL} )
+option( BUILD_STYLE_PLUGIN_ALL "Build all styles as plugins" OFF )
+option( BUILD_STYLE_PLUGIN_MOTIF "Build Motif style as plugin" ${BUILD_STYLE_PLUGIN_ALL} )
+option( BUILD_STYLE_PLUGIN_WINDOWS "Build Windows style as plugin" ${BUILD_STYLE_PLUGIN_ALL} )
+option( BUILD_STYLE_PLUGIN_CDE "Build CDE style as plugin" ${BUILD_STYLE_PLUGIN_ALL} )
+option( BUILD_STYLE_PLUGIN_MOTIFPLUS "Build Motif plus style as plugin" ${BUILD_STYLE_PLUGIN_ALL} )
+option( BUILD_STYLE_PLUGIN_SGI "Build SGI style as plugin" ${BUILD_STYLE_PLUGIN_ALL} )
+option( BUILD_STYLE_PLUGIN_COMPACT "Build compact style as plugin" ${BUILD_STYLE_PLUGIN_ALL} )
+option( BUILD_STYLE_PLUGIN_PLATINUM "Build platinium style as plugin" ${BUILD_STYLE_PLUGIN_ALL} )
+option( BUILD_STYLE_PLUGIN_INTERLACE "Build interlace style as plugin" OFF )
+
+
+option( WITH_STYLE_ALL "Build all style" ${WITH_ALL_OPTIONS} )
+option( WITH_STYLE_MOTIF "Build Motif style" ${WITH_STYLE_ALL} )
+option( WITH_STYLE_WINDOWS "Build Windows style" ${WITH_STYLE_ALL} )
## Depend upon WITH_MOTIF_STYLE
-option( WITH_STYLE_CDE "Build CDE style" ${WITH_STYLES_ALL} )
-option( WITH_STYLE_MOTIFPLUS "Build Motif plus style" ${WITH_STYLES_ALL} )
-option( WITH_STYLE_SGI "Build SGI style" ${WITH_STYLES_ALL} )
+option( WITH_STYLE_CDE "Build CDE style" ${WITH_STYLE_ALL} )
+option( WITH_STYLE_MOTIFPLUS "Build Motif plus style" ${WITH_STYLE_ALL} )
+option( WITH_STYLE_SGI "Build SGI style" ${WITH_STYLE_ALL} )
## Depend upon WITH_WINDOWS_STYLE
-option( WITH_STYLE_COMPACT "Build compact style" ${WITH_STYLES_ALL} )
-option( WITH_STYLE_PLATINUM "Build platinium style" ${WITH_STYLES_ALL} )
+option( WITH_STYLE_COMPACT "Build compact style" ${WITH_STYLE_ALL} )
+option( WITH_STYLE_PLATINUM "Build platinium style" ${WITH_STYLE_ALL} )
option( WITH_STYLE_INTERLACE "Build interlace style" OFF )
## NOTE: Interlace is OFF by default due to it being experimental