summaryrefslogtreecommitdiffstats
path: root/qtinterface/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-06-19 16:43:28 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-06-19 16:43:28 -0500
commit246b93316fe28682e9b687ec8b6b4733f1223c27 (patch)
treeec3f152e20e2e101ba8eec2328a7151e6011de80 /qtinterface/CMakeLists.txt
parent7a453a2786058eafb7a89fb66de4eb09ddfd4098 (diff)
downloadtqtinterface-246b93316fe28682e9b687ec8b6b4733f1223c27.tar.gz
tqtinterface-246b93316fe28682e9b687ec8b6b4733f1223c27.zip
Use tqt3 binaries if available
Diffstat (limited to 'qtinterface/CMakeLists.txt')
-rw-r--r--qtinterface/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/qtinterface/CMakeLists.txt b/qtinterface/CMakeLists.txt
index 8633d8d..c0c5f74 100644
--- a/qtinterface/CMakeLists.txt
+++ b/qtinterface/CMakeLists.txt
@@ -110,6 +110,7 @@ install(
##### tqt tools #################################
configure_file( ${IFACE}/tmoc.cmake tmoc @ONLY )
+configure_file( uic-tqt.cmake uic-tqt @ONLY )
if ( NOT HAVE_REAL_TQT )
configure_file( tqt-replace.cmake tqt-replace @ONLY )
configure_file( tqt-replace-stream.cmake tqt-replace-stream @ONLY )
@@ -119,7 +120,8 @@ else ()
endif ()
install( PROGRAMS
- moc-tqt uic-tqt mcopidl-tqt dcopidl-tqt dcopidlng-tqt
+ moc-tqt ${CMAKE_CURRENT_BINARY_DIR}/uic-tqt
+ mcopidl-tqt dcopidl-tqt dcopidlng-tqt
dcopidl2cpp-tqt convert_qt_tqt1 convert_qt_tqt2
convert_qt_tqt3 ${CMAKE_CURRENT_BINARY_DIR}/tmoc
${CMAKE_CURRENT_BINARY_DIR}/tqt-replace