summaryrefslogtreecommitdiffstats
path: root/qtinterface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qtinterface/CMakeLists.txt')
-rw-r--r--qtinterface/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/qtinterface/CMakeLists.txt b/qtinterface/CMakeLists.txt
index 0e67c5a..b8b06aa 100644
--- a/qtinterface/CMakeLists.txt
+++ b/qtinterface/CMakeLists.txt
@@ -27,6 +27,10 @@ link_directories(
${TQT_LIBRARY_DIR}
)
+if ( INPUTMETHOD_ENABLED )
+ set( INPUTMETHOD_HEADERS ${IFACE}/tqinputcontext.h ${IFACE}/tqinputcontextfactory.h ${IFACE}/tqinputcontextplugin.h )
+ set( INPUTMETHOD_SOURCES ${IFACE}/tqinputcontext.cpp ${IFACE}/tqinputcontextfactory.cpp ${IFACE}/tqinputcontextplugin.cpp )
+endif()
##### headers ###################################
@@ -95,6 +99,7 @@ install( FILES
${IFACE}/private/tqlayoutengine_p.h ${IFACE}/private/tqinternal_p.h ${IFACE}/private/tqeffects_p.h
${IFACE}/private/tqrichtext_p.h ${IFACE}/private/tqpluginmanager_p.h ${IFACE}/private/tqcom_p.h
${IFACE}/private/tqucom_p.h ${IFACE}/private/tqwidgetinterface_p.h ${IFACE}/private/tqtextengine_p.h
+ ${INPUTMETHOD_HEADERS}
DESTINATION ${INCLUDE_INSTALL_DIR} )
##### tqt tools #################################
@@ -192,6 +197,7 @@ tde_add_library( tqt SHARED
${IFACE}/tqvaluelist.cpp ${IFACE}/tqvaluestack.cpp ${IFACE}/tqvaluevector.cpp ${IFACE}/tqvariant.cpp ${IFACE}/tqvfbhdr.cpp
${IFACE}/tqwaitcondition.cpp ${IFACE}/tqwhatsthis.cpp ${IFACE}/tqwidgetfactory.cpp ${IFACE}/tqwidgetintdict.cpp
${IFACE}/tqwidgetlist.cpp ${IFACE}/tqwmatrix.cpp ${IFACE}/tqxml.cpp ${IFACE}/private/tqucomextra_p.cpp
+ ${INPUTMETHOD_SOURCES}
VERSION 4.2.0
LINK ${TQT_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}