summaryrefslogtreecommitdiffstats
path: root/qtinterface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qtinterface/CMakeLists.txt')
-rw-r--r--qtinterface/CMakeLists.txt250
1 files changed, 128 insertions, 122 deletions
diff --git a/qtinterface/CMakeLists.txt b/qtinterface/CMakeLists.txt
index 9803386..0596911 100644
--- a/qtinterface/CMakeLists.txt
+++ b/qtinterface/CMakeLists.txt
@@ -25,70 +25,76 @@ link_directories(
configure_file( tqt.h.cmake tqt.h @ONLY )
+if ( NOT HAVE_REAL_TQT )
+ set( IFACE "interface_qt3" )
+else ( NOT HAVE_REAL_TQT )
+ set( IFACE "interface_tqt3" )
+endif ( NOT HAVE_REAL_TQT )
+
install( FILES
- ${CMAKE_CURRENT_BINARY_DIR}/tqt.h tqtglobaldefines.h tqaccel.h tqaccessible.h
- tqaction.h tqapplication.h tqasyncio.h tqbuttongroup.h tqbutton.h tqcanvas.h
- tqcdestyle.h tqcheckbox.h tqclipboard.h tqcolordialog.h tqcombobox.h
- tqcommonstyle.h tqdatabrowser.h tqdatatable.h tqdataview.h tqdatetimeedit.h
- tqdesktopwidget.h tqdial.h tqdialog.h tqdns.h tqdockarea.h tqdockwindow.h
- tqdragobject.h tqerrormessage.h tqeventloop.h tqfiledialog.h tqfontdialog.h
- tqframe.h tqftp.h tqgl.h tqgplugin.h tqgrid.h tqgridview.h tqgroupbox.h
- tqguardedptr.h tqhbox.h tqhbuttongroup.h tqheader.h tqhgroupbox.h
- tqhttp.h tqiconview.h tqimageformatplugin.h tqinputdialog.h tqlabel.h
- tqlayout.h tqlcdnumber.h tqlineedit.h tqlistbox.h tqlistview.h tqlocalfs.h
- tqmainwindow.h tqmenubar.h tqmessagebox.h tqmotifplusstyle.h tqmotifstyle.h
- tqmultilineedit.h tqnetworkprotocol.h tqnp.h tqobjectcleanuphandler.h
- tqobject.h tqplatinumstyle.h tqpopupmenu.h tqprintdialog.h tqprocess.h
- tqprogressbar.h tqprogressdialog.h tqpushbutton.h tqradiobutton.h
- tqrangecontrol.h tqscrollbar.h tqscrollview.h tqsemimodal.h tqserversocket.h
- tqsessionmanager.h tqsgistyle.h tqsignal.h tqsignalmapper.h tqsizegrip.h
- tqslider.h tqsocket.h tqsocketnotifier.h tqsound.h tqspinbox.h tqsplashscreen.h
- tqsplitter.h tqsqldatabase.h tqsqldriver.h tqsqldriverplugin.h tqsqlform.h
- tqsqlquery.h tqstatusbar.h tqstyle.h tqstyleplugin.h tqstylesheet.h tqtabbar.h
- tqtabdialog.h tqtable.h tqtabwidget.h tqtextbrowser.h tqtextcodecplugin.h
- tqtextedit.h tqtextview.h tqtimer.h tqtoolbar.h tqtoolbox.h tqtoolbutton.h
- tqtooltip.h tqtranslator.h tqurloperator.h tqvalidator.h tqvbox.h
- tqvbuttongroup.h tqvgroupbox.h tqwidget.h tqwidgetplugin.h tqwidgetstack.h
- tqwindowsstyle.h tqwizard.h tqworkspace.h tqapp.h tqarray.h tqassistantclient.h
- tqbitarry.h tqbttngrp.h tqchkbox.h tqclipbrd.h tqcollect.h tqcollection.h tqcombo.h
- tqconfig.h tqconnect.h tqdatetm.h tqdrawutl.h tqdstream.h tqfeatures.h
- tqfiledef.h tqfiledlg.h tqfileinf.h tqfontinf.h tqfontmet.h tqgbkcodec.h
- tqgeneric.h tqgif.h tqglobal.h tqgrpbox.h tqintcach.h tqiodev.h tqjpegio.h
- tqkeycode.h tqlined.h tqlist.h tqmenudta.h tqmetaobj.h tqmlined.h tqmngio.h
- tqmodules.h tqmsgbox.h tqmultilinedit.h tqnetwork.h tqobjcoll.h tqobjdefs.h
- tqpaintdc.h tqpaintd.h tqpdevmet.h tqpmcache.h tqpntarry.h tqpopmenu.h
- tqprndlg.h tqprogbar.h tqprogdlg.h tqpushbt.h tqqueue.h tqradiobt.h tqrangect.h
- tqscrbar.h tqsession.h tqsocknot.h tqstack.h tqtabdlg.h tqtstream.h tqvector.h
- tqwidcoll.h tqwindefs.h tqwindowdefs.h tqwinexport.h tq1xcompatibility.h
- tqabstractlayout.h tqasciicache.h tqasciidict.h tqasyncimageio.h tqbig5codec.h
- tqbitarray.h tqbitmap.h tqbrush.h tqbuffer.h tqcache.h tqcleanuphandler.h
- tqcolor.h tqcompactstyle.h tqconnection.h tqcstring.h tqcursor.h tqdatastream.h
- tqdatetime.h tqdeepcopy.h tqdict.h tqdir.h tqdom.h tqdrawutil.h tqdropsite.h
- tqeditorfactory.h tqeucjpcodec.h tqeuckrcodec.h tqevent.h tqfile.h tqfileinfo.h
- tqfocusdata.h tqfontdatabase.h tqfont.h tqfontinfo.h tqfontmetrics.h
- tqgarray.h tqgb18030codec.h tqgcache.h tqgdict.h tqglcolormap.h tqglist.h
- tqgvector.h tqhostaddress.h tqiconset.h tqimage.h tqintcache.h tqintdict.h
- tqinterlacestyle.h tqiodevice.h tqjiscodec.h tqjpunicode.h tqkeysequence.h
- tqlibrary.h tqlocale.h tqmap.h tqmemarray.h tqmenudata.h tqmetaobject.h
- tqmime.h tqmovie.h tqmutex.h tqnamespace.h tqobjectdict.h tqobjectlist.h
- tqpaintdevice.h tqpaintdevicemetrics.h tqpainter.h tqpair.h tqpalette.h tqpen.h
- tqpicture.h tqpixmapcache.h tqpixmap.h tqpngio.h tqpointarray.h tqpoint.h
- tqpolygonscanner.h tqprinter.h tqptrcollection.h tqptrdict.h tqptrlist.h
- tqptrqueue.h tqptrstack.h tqptrvector.h tqrect.h tqregexp.h tqregion.h
- tqrtlcodec.h tqsemaphore.h tqsettings.h tqshared.h tqsignalslotimp.h
- tqsimplerichtext.h tqsize.h tqsizepolicy.h tqsjiscodec.h tqsocketdevice.h
- tqsortedlist.h tqsqlcursor.h tqsqleditorfactory.h tqsqlerror.h tqsqlfield.h
- tqsql.h tqsqlindex.h tqsqlpropertymap.h tqsqlrecord.h tqsqlresult.h
- tqsqlselectcursor.h tqstring.h tqstringlist.h tqstrlist.h tqstrvec.h
- tqstylefactory.h tqsyntaxhighlighter.h tqtextcodecfactory.h tqtextcodec.h
- tqtextstream.h tqthread.h tqthreadstorage.h tqtl.h tqtsciicodec.h tqurl.h
- tqurlinfo.h tqutfcodec.h tquuid.h tqvaluelist.h tqvaluestack.h tqvaluevector.h
- tqvariant.h tqvfbhdr.h tqwaitcondition.h tqwhatsthis.h tqwidgetfactory.h
- tqwidgetintdict.h tqwidgetlist.h tqwmatrix.h tqxml.h private/tqucomextra_p.h
- private/tqlayoutengine_p.h private/tqinternal_p.h private/tqeffects_p.h
- private/tqrichtext_p.h private/tqpluginmanager_p.h private/tqcom_p.h
- private/tqucom_p.h private/tqwidgetinterface_p.h private/tqtextengine_p.h
- tqlistiterator.h
+ ${CMAKE_CURRENT_BINARY_DIR}/tqt.h ${IFACE}/tglobaldefines.h ${IFACE}/accel.h ${IFACE}/accessible.h
+ ${IFACE}/action.h ${IFACE}/application.h ${IFACE}/asyncio.h ${IFACE}/buttongroup.h ${IFACE}/button.h ${IFACE}/canvas.h
+ ${IFACE}/cdestyle.h ${IFACE}/checkbox.h ${IFACE}/clipboard.h ${IFACE}/colordialog.h ${IFACE}/combobox.h
+ ${IFACE}/commonstyle.h ${IFACE}/databrowser.h ${IFACE}/datatable.h ${IFACE}/dataview.h ${IFACE}/datetimeedit.h
+ ${IFACE}/desktopwidget.h ${IFACE}/dial.h ${IFACE}/dialog.h ${IFACE}/dns.h ${IFACE}/dockarea.h ${IFACE}/dockwindow.h
+ ${IFACE}/dragobject.h ${IFACE}/errormessage.h ${IFACE}/eventloop.h ${IFACE}/filedialog.h ${IFACE}/fontdialog.h
+ ${IFACE}/frame.h ${IFACE}/ftp.h ${IFACE}/gl.h ${IFACE}/gplugin.h ${IFACE}/grid.h ${IFACE}/gridview.h ${IFACE}/groupbox.h
+ ${IFACE}/guardedptr.h ${IFACE}/hbox.h ${IFACE}/hbuttongroup.h ${IFACE}/header.h ${IFACE}/hgroupbox.h
+ ${IFACE}/http.h ${IFACE}/iconview.h ${IFACE}/imageformatplugin.h ${IFACE}/inputdialog.h ${IFACE}/label.h
+ ${IFACE}/layout.h ${IFACE}/lcdnumber.h ${IFACE}/lineedit.h ${IFACE}/listbox.h ${IFACE}/listview.h ${IFACE}/localfs.h
+ ${IFACE}/mainwindow.h ${IFACE}/menubar.h ${IFACE}/messagebox.h ${IFACE}/motifplusstyle.h ${IFACE}/motifstyle.h
+ ${IFACE}/multilineedit.h ${IFACE}/networkprotocol.h ${IFACE}/np.h ${IFACE}/objectcleanuphandler.h
+ ${IFACE}/object.h ${IFACE}/platinumstyle.h ${IFACE}/popupmenu.h ${IFACE}/printdialog.h ${IFACE}/process.h
+ ${IFACE}/progressbar.h ${IFACE}/progressdialog.h ${IFACE}/pushbutton.h ${IFACE}/radiobutton.h
+ ${IFACE}/rangecontrol.h ${IFACE}/scrollbar.h ${IFACE}/scrollview.h ${IFACE}/semimodal.h ${IFACE}/serversocket.h
+ ${IFACE}/sessionmanager.h ${IFACE}/sgistyle.h ${IFACE}/signal.h ${IFACE}/signalmapper.h ${IFACE}/sizegrip.h
+ ${IFACE}/slider.h ${IFACE}/socket.h ${IFACE}/socketnotifier.h ${IFACE}/sound.h ${IFACE}/spinbox.h ${IFACE}/splashscreen.h
+ ${IFACE}/splitter.h ${IFACE}/sqldatabase.h ${IFACE}/sqldriver.h ${IFACE}/sqldriverplugin.h ${IFACE}/sqlform.h
+ ${IFACE}/sqlquery.h ${IFACE}/statusbar.h ${IFACE}/style.h ${IFACE}/styleplugin.h ${IFACE}/stylesheet.h ${IFACE}/tabbar.h
+ ${IFACE}/tabdialog.h ${IFACE}/table.h ${IFACE}/tabwidget.h ${IFACE}/textbrowser.h ${IFACE}/textcodecplugin.h
+ ${IFACE}/textedit.h ${IFACE}/textview.h ${IFACE}/timer.h ${IFACE}/toolbar.h ${IFACE}/toolbox.h ${IFACE}/toolbutton.h
+ ${IFACE}/tooltip.h ${IFACE}/translator.h ${IFACE}/urloperator.h ${IFACE}/validator.h ${IFACE}/vbox.h
+ ${IFACE}/vbuttongroup.h ${IFACE}/vgroupbox.h ${IFACE}/widget.h ${IFACE}/widgetplugin.h ${IFACE}/widgetstack.h
+ ${IFACE}/windowsstyle.h ${IFACE}/wizard.h ${IFACE}/workspace.h ${IFACE}/app.h ${IFACE}/array.h ${IFACE}/assistantclient.h
+ ${IFACE}/bitarry.h ${IFACE}/bttngrp.h ${IFACE}/chkbox.h ${IFACE}/clipbrd.h ${IFACE}/collect.h ${IFACE}/collection.h ${IFACE}/combo.h
+ ${IFACE}/config.h ${IFACE}/connect.h ${IFACE}/datetm.h ${IFACE}/drawutl.h ${IFACE}/dstream.h ${IFACE}/features.h
+ ${IFACE}/filedef.h ${IFACE}/filedlg.h ${IFACE}/fileinf.h ${IFACE}/fontinf.h ${IFACE}/fontmet.h ${IFACE}/gbkcodec.h
+ ${IFACE}/generic.h ${IFACE}/gif.h ${IFACE}/global.h ${IFACE}/grpbox.h ${IFACE}/intcach.h ${IFACE}/iodev.h ${IFACE}/jpegio.h
+ ${IFACE}/keycode.h ${IFACE}/lined.h ${IFACE}/list.h ${IFACE}/menudta.h ${IFACE}/metaobj.h ${IFACE}/mlined.h ${IFACE}/mngio.h
+ ${IFACE}/modules.h ${IFACE}/msgbox.h ${IFACE}/multilinedit.h ${IFACE}/network.h ${IFACE}/objcoll.h ${IFACE}/objdefs.h
+ ${IFACE}/paintdc.h ${IFACE}/paintd.h ${IFACE}/pdevmet.h ${IFACE}/pmcache.h ${IFACE}/pntarry.h ${IFACE}/popmenu.h
+ ${IFACE}/prndlg.h ${IFACE}/progbar.h ${IFACE}/progdlg.h ${IFACE}/pushbt.h ${IFACE}/queue.h ${IFACE}/radiobt.h ${IFACE}/rangect.h
+ ${IFACE}/scrbar.h ${IFACE}/session.h ${IFACE}/socknot.h ${IFACE}/stack.h ${IFACE}/tabdlg.h ${IFACE}/tstream.h ${IFACE}/vector.h
+ ${IFACE}/widcoll.h ${IFACE}/windefs.h ${IFACE}/windowdefs.h ${IFACE}/winexport.h ${IFACE}/1xcompatibility.h
+ ${IFACE}/abstractlayout.h ${IFACE}/asciicache.h ${IFACE}/asciidict.h ${IFACE}/asyncimageio.h ${IFACE}/big5codec.h
+ ${IFACE}/bitarray.h ${IFACE}/bitmap.h ${IFACE}/brush.h ${IFACE}/buffer.h ${IFACE}/cache.h ${IFACE}/cleanuphandler.h
+ ${IFACE}/color.h ${IFACE}/compactstyle.h ${IFACE}/connection.h ${IFACE}/cstring.h ${IFACE}/cursor.h ${IFACE}/datastream.h
+ ${IFACE}/datetime.h ${IFACE}/deepcopy.h ${IFACE}/dict.h ${IFACE}/dir.h ${IFACE}/dom.h ${IFACE}/drawutil.h ${IFACE}/dropsite.h
+ ${IFACE}/editorfactory.h ${IFACE}/eucjpcodec.h ${IFACE}/euckrcodec.h ${IFACE}/event.h ${IFACE}/file.h ${IFACE}/fileinfo.h
+ ${IFACE}/focusdata.h ${IFACE}/fontdatabase.h ${IFACE}/font.h ${IFACE}/fontinfo.h ${IFACE}/fontmetrics.h
+ ${IFACE}/garray.h ${IFACE}/gb18030codec.h ${IFACE}/gcache.h ${IFACE}/gdict.h ${IFACE}/glcolormap.h ${IFACE}/glist.h
+ ${IFACE}/gvector.h ${IFACE}/hostaddress.h ${IFACE}/iconset.h ${IFACE}/image.h ${IFACE}/intcache.h ${IFACE}/intdict.h
+ ${IFACE}/interlacestyle.h ${IFACE}/iodevice.h ${IFACE}/jiscodec.h ${IFACE}/jpunicode.h ${IFACE}/keysequence.h
+ ${IFACE}/library.h ${IFACE}/locale.h ${IFACE}/map.h ${IFACE}/memarray.h ${IFACE}/menudata.h ${IFACE}/metaobject.h
+ ${IFACE}/mime.h ${IFACE}/movie.h ${IFACE}/mutex.h ${IFACE}/namespace.h ${IFACE}/objectdict.h ${IFACE}/objectlist.h
+ ${IFACE}/paintdevice.h ${IFACE}/paintdevicemetrics.h ${IFACE}/painter.h ${IFACE}/pair.h ${IFACE}/palette.h ${IFACE}/pen.h
+ ${IFACE}/picture.h ${IFACE}/pixmapcache.h ${IFACE}/pixmap.h ${IFACE}/pngio.h ${IFACE}/pointarray.h ${IFACE}/point.h
+ ${IFACE}/polygonscanner.h ${IFACE}/printer.h ${IFACE}/ptrcollection.h ${IFACE}/ptrdict.h ${IFACE}/ptrlist.h
+ ${IFACE}/ptrqueue.h ${IFACE}/ptrstack.h ${IFACE}/ptrvector.h ${IFACE}/rect.h ${IFACE}/regexp.h ${IFACE}/region.h
+ ${IFACE}/rtlcodec.h ${IFACE}/semaphore.h ${IFACE}/settings.h ${IFACE}/shared.h ${IFACE}/signalslotimp.h
+ ${IFACE}/simplerichtext.h ${IFACE}/size.h ${IFACE}/sizepolicy.h ${IFACE}/sjiscodec.h ${IFACE}/socketdevice.h
+ ${IFACE}/sortedlist.h ${IFACE}/sqlcursor.h ${IFACE}/sqleditorfactory.h ${IFACE}/sqlerror.h ${IFACE}/sqlfield.h
+ ${IFACE}/sql.h ${IFACE}/sqlindex.h ${IFACE}/sqlpropertymap.h ${IFACE}/sqlrecord.h ${IFACE}/sqlresult.h
+ ${IFACE}/sqlselectcursor.h ${IFACE}/string.h ${IFACE}/stringlist.h ${IFACE}/strlist.h ${IFACE}/strvec.h
+ ${IFACE}/stylefactory.h ${IFACE}/syntaxhighlighter.h ${IFACE}/textcodecfactory.h ${IFACE}/textcodec.h
+ ${IFACE}/textstream.h ${IFACE}/thread.h ${IFACE}/threadstorage.h ${IFACE}/tl.h ${IFACE}/tsciicodec.h ${IFACE}/url.h
+ ${IFACE}/urlinfo.h ${IFACE}/utfcodec.h ${IFACE}/uuid.h ${IFACE}/valuelist.h ${IFACE}/valuestack.h ${IFACE}/valuevector.h
+ ${IFACE}/variant.h ${IFACE}/vfbhdr.h ${IFACE}/waitcondition.h ${IFACE}/whatsthis.h ${IFACE}/widgetfactory.h
+ ${IFACE}/widgetintdict.h ${IFACE}/widgetlist.h ${IFACE}/wmatrix.h ${IFACE}/xml.h ${IFACE}/private/tqucomextra_p.h
+ ${IFACE}/private/tqlayoutengine_p.h ${IFACE}/private/tqinternal_p.h ${IFACE}/private/tqeffects_p.h
+ ${IFACE}/private/tqrichtext_p.h ${IFACE}/private/tqpluginmanager_p.h ${IFACE}/private/tqcom_p.h
+ ${IFACE}/private/tqucom_p.h ${IFACE}/private/tqwidgetinterface_p.h ${IFACE}/private/tqtextengine_p.h
+ ${IFACE}/listiterator.h
DESTINATION ${INCLUDE_INSTALL_DIR} )
install(
@@ -136,66 +142,66 @@ install( FILES ${CMAKE_CURRENT_BINARY_DIR}/tqt.pc DESTINATION ${PKGCONFIG_INSTAL
##### tqt (shared) ##############################
-tde_add_library( tqt SHARED
+tde_add_library( ${IFACE}/t SHARED
SOURCES
- tqt.cpp tqaccel.cpp tqaccessible.cpp tqaction.cpp tqapplication.cpp
- tqasyncio.cpp tqbuttongroup.cpp tqbutton.cpp tqcanvas.cpp tqcdestyle.cpp
- tqcheckbox.cpp tqclipboard.cpp tqcolordialog.cpp tqcombobox.cpp
- tqcommonstyle.cpp tqdatabrowser.cpp tqdatatable.cpp tqdataview.cpp
- tqdatetimeedit.cpp tqdesktopwidget.cpp tqdial.cpp tqdialog.cpp tqdns.cpp
- tqdockarea.cpp tqdockwindow.cpp tqdragobject.cpp tqerrormessage.cpp
- tqeventloop.cpp tqframe.cpp tqftp.cpp tqfiledialog.cpp tqfontdialog.cpp
- tqgl.cpp tqgplugin.cpp tqgrid.cpp tqgridview.cpp tqgroupbox.cpp
- tqguardedptr.cpp tqhbox.cpp tqhbuttongroup.cpp tqheader.cpp
- tqhgroupbox.cpp tqhttp.cpp tqiconview.cpp tqimageformatplugin.cpp
- tqinputdialog.cpp tqlabel.cpp tqlayout.cpp tqlcdnumber.cpp tqlineedit.cpp
- tqlistbox.cpp tqlistview.cpp tqlocalfs.cpp tqmainwindow.cpp tqmenubar.cpp
- tqmessagebox.cpp tqmotifplusstyle.cpp tqmotifstyle.cpp tqmultilineedit.cpp
- tqnetworkprotocol.cpp tqnp.cpp tqobjectcleanuphandler.cpp tqobject.cpp
- tqplatinumstyle.cpp tqpopupmenu.cpp tqprintdialog.cpp tqprocess.cpp
- tqprogressbar.cpp tqprogressdialog.cpp tqpushbutton.cpp tqradiobutton.cpp
- tqrangecontrol.cpp tqscrollbar.cpp tqscrollview.cpp tqsemimodal.cpp
- tqserversocket.cpp tqsessionmanager.cpp tqsgistyle.cpp tqsignal.cpp
- tqsignalmapper.cpp tqsizegrip.cpp tqslider.cpp tqsocket.cpp
- tqsocketnotifier.cpp tqsound.cpp tqspinbox.cpp tqsplashscreen.cpp
- tqsplitter.cpp tqsqldatabase.cpp tqsqldriver.cpp tqsqldriverplugin.cpp
- tqsqlform.cpp tqsqlquery.cpp tqstatusbar.cpp tqstyle.cpp tqstyleplugin.cpp
- tqstylesheet.cpp tqtabbar.cpp tqtabdialog.cpp tqtable.cpp tqtabwidget.cpp
- tqtextbrowser.cpp tqtextcodecplugin.cpp tqtextedit.cpp tqtextview.cpp
- tqtimer.cpp tqtoolbar.cpp tqtoolbox.cpp tqtoolbutton.cpp tqtooltip.cpp
- tqtranslator.cpp tqurloperator.cpp tqvalidator.cpp tqvbox.cpp
- tqvbuttongroup.cpp tqvgroupbox.cpp tqwidget.cpp tqwidgetplugin.cpp
- tqwidgetstack.cpp tqwindowsstyle.cpp tqwizard.cpp tqworkspace.cpp
- tq1xcompatibility.cpp tqabstractlayout.cpp tqasciicache.cpp tqasciidict.cpp
- tqasyncimageio.cpp tqbig5codec.cpp tqbitarray.cpp tqbitmap.cpp tqbrush.cpp
- tqbuffer.cpp tqcache.cpp tqcleanuphandler.cpp tqcolor.cpp tqcompactstyle.cpp
- tqconnection.cpp tqcstring.cpp tqcursor.cpp tqdatastream.cpp tqdatetime.cpp
- tqdeepcopy.cpp tqdict.cpp tqdir.cpp tqdom.cpp tqdrawutil.cpp tqdropsite.cpp
- tqeditorfactory.cpp tqeucjpcodec.cpp tqeuckrcodec.cpp tqevent.cpp tqfile.cpp
- tqfileinfo.cpp tqfocusdata.cpp tqfontdatabase.cpp tqfont.cpp tqfontinfo.cpp
- tqfontmetrics.cpp tqgarray.cpp tqgb18030codec.cpp tqgcache.cpp tqgdict.cpp
- tqglcolormap.cpp tqglist.cpp tqgvector.cpp tqhostaddress.cpp tqiconset.cpp
- tqimage.cpp tqintcache.cpp tqintdict.cpp tqinterlacestyle.cpp tqiodevice.cpp
- tqjiscodec.h tqjpunicode.cpp tqkeysequence.cpp tqlibrary.cpp tqlocale.cpp
- tqmap.cpp tqmemarray.cpp tqmenudata.cpp tqmetaobject.cpp tqmime.cpp tqmovie.cpp
- tqmutex.cpp tqnamespace.cpp tqobjectdict.cpp tqobjectlist.cpp tqpaintdevice.cpp
- tqpaintdevicemetrics.cpp tqpainter.cpp tqpair.cpp tqpalette.cpp tqpen.cpp
- tqpicture.cpp tqpixmapcache.cpp tqpixmap.cpp tqpngio.cpp tqpointarray.cpp
- tqpoint.cpp tqpolygonscanner.cpp tqprinter.cpp tqptrcollection.cpp
- tqptrdict.cpp tqptrlist.cpp tqptrqueue.cpp tqptrstack.cpp tqptrvector.cpp
- tqrect.cpp tqregexp.cpp tqregion.cpp tqrtlcodec.cpp tqsemaphore.cpp
- tqsettings.cpp tqshared.cpp tqsignalslotimp.cpp tqsimplerichtext.cpp tqsize.cpp
- tqsizepolicy.cpp tqsjiscodec.cpp tqsocketdevice.cpp tqsortedlist.cpp
- tqsqlcursor.cpp tqsqleditorfactory.cpp tqsqlerror.cpp tqsqlfield.cpp
- tqsql.cpp tqsqlindex.cpp tqsqlpropertymap.cpp tqsqlrecord.cpp tqsqlresult.cpp
- tqsqlselectcursor.cpp tqstring.cpp tqstringlist.cpp tqstrlist.cpp tqstrvec.cpp
- tqstylefactory.cpp tqsyntaxhighlighter.cpp tqtextcodecfactory.cpp
- tqtextcodec.cpp tqtextstream.cpp tqthread.cpp tqthreadstorage.cpp
- tqtl.cpp tqtsciicodec.cpp tqurl.cpp tqurlinfo.cpp tqutfcodec.cpp tquuid.cpp
- tqvaluelist.cpp tqvaluestack.cpp tqvaluevector.cpp tqvariant.cpp tqvfbhdr.cpp
- tqwaitcondition.cpp tqwhatsthis.cpp tqwidgetfactory.cpp tqwidgetintdict.cpp
- tqwidgetlist.cpp tqwmatrix.cpp tqxml.cpp private/tqucomextra_p.cpp
- tqlistiterator.cpp
+ ${IFACE}/t.cpp ${IFACE}/accel.cpp ${IFACE}/accessible.cpp ${IFACE}/action.cpp ${IFACE}/application.cpp
+ ${IFACE}/asyncio.cpp ${IFACE}/buttongroup.cpp ${IFACE}/button.cpp ${IFACE}/canvas.cpp ${IFACE}/cdestyle.cpp
+ ${IFACE}/checkbox.cpp ${IFACE}/clipboard.cpp ${IFACE}/colordialog.cpp ${IFACE}/combobox.cpp
+ ${IFACE}/commonstyle.cpp ${IFACE}/databrowser.cpp ${IFACE}/datatable.cpp ${IFACE}/dataview.cpp
+ ${IFACE}/datetimeedit.cpp ${IFACE}/desktopwidget.cpp ${IFACE}/dial.cpp ${IFACE}/dialog.cpp ${IFACE}/dns.cpp
+ ${IFACE}/dockarea.cpp ${IFACE}/dockwindow.cpp ${IFACE}/dragobject.cpp ${IFACE}/errormessage.cpp
+ ${IFACE}/eventloop.cpp ${IFACE}/frame.cpp ${IFACE}/ftp.cpp ${IFACE}/filedialog.cpp ${IFACE}/fontdialog.cpp
+ ${IFACE}/gl.cpp ${IFACE}/gplugin.cpp ${IFACE}/grid.cpp ${IFACE}/gridview.cpp ${IFACE}/groupbox.cpp
+ ${IFACE}/guardedptr.cpp ${IFACE}/hbox.cpp ${IFACE}/hbuttongroup.cpp ${IFACE}/header.cpp
+ ${IFACE}/hgroupbox.cpp ${IFACE}/http.cpp ${IFACE}/iconview.cpp ${IFACE}/imageformatplugin.cpp
+ ${IFACE}/inputdialog.cpp ${IFACE}/label.cpp ${IFACE}/layout.cpp ${IFACE}/lcdnumber.cpp ${IFACE}/lineedit.cpp
+ ${IFACE}/listbox.cpp ${IFACE}/listview.cpp ${IFACE}/localfs.cpp ${IFACE}/mainwindow.cpp ${IFACE}/menubar.cpp
+ ${IFACE}/messagebox.cpp ${IFACE}/motifplusstyle.cpp ${IFACE}/motifstyle.cpp ${IFACE}/multilineedit.cpp
+ ${IFACE}/networkprotocol.cpp ${IFACE}/np.cpp ${IFACE}/objectcleanuphandler.cpp ${IFACE}/object.cpp
+ ${IFACE}/platinumstyle.cpp ${IFACE}/popupmenu.cpp ${IFACE}/printdialog.cpp ${IFACE}/process.cpp
+ ${IFACE}/progressbar.cpp ${IFACE}/progressdialog.cpp ${IFACE}/pushbutton.cpp ${IFACE}/radiobutton.cpp
+ ${IFACE}/rangecontrol.cpp ${IFACE}/scrollbar.cpp ${IFACE}/scrollview.cpp ${IFACE}/semimodal.cpp
+ ${IFACE}/serversocket.cpp ${IFACE}/sessionmanager.cpp ${IFACE}/sgistyle.cpp ${IFACE}/signal.cpp
+ ${IFACE}/signalmapper.cpp ${IFACE}/sizegrip.cpp ${IFACE}/slider.cpp ${IFACE}/socket.cpp
+ ${IFACE}/socketnotifier.cpp ${IFACE}/sound.cpp ${IFACE}/spinbox.cpp ${IFACE}/splashscreen.cpp
+ ${IFACE}/splitter.cpp ${IFACE}/sqldatabase.cpp ${IFACE}/sqldriver.cpp ${IFACE}/sqldriverplugin.cpp
+ ${IFACE}/sqlform.cpp ${IFACE}/sqlquery.cpp ${IFACE}/statusbar.cpp ${IFACE}/style.cpp ${IFACE}/styleplugin.cpp
+ ${IFACE}/stylesheet.cpp ${IFACE}/tabbar.cpp ${IFACE}/tabdialog.cpp ${IFACE}/table.cpp ${IFACE}/tabwidget.cpp
+ ${IFACE}/textbrowser.cpp ${IFACE}/textcodecplugin.cpp ${IFACE}/textedit.cpp ${IFACE}/textview.cpp
+ ${IFACE}/timer.cpp ${IFACE}/toolbar.cpp ${IFACE}/toolbox.cpp ${IFACE}/toolbutton.cpp ${IFACE}/tooltip.cpp
+ ${IFACE}/translator.cpp ${IFACE}/urloperator.cpp ${IFACE}/validator.cpp ${IFACE}/vbox.cpp
+ ${IFACE}/vbuttongroup.cpp ${IFACE}/vgroupbox.cpp ${IFACE}/widget.cpp ${IFACE}/widgetplugin.cpp
+ ${IFACE}/widgetstack.cpp ${IFACE}/windowsstyle.cpp ${IFACE}/wizard.cpp ${IFACE}/workspace.cpp
+ ${IFACE}/1xcompatibility.cpp ${IFACE}/abstractlayout.cpp ${IFACE}/asciicache.cpp ${IFACE}/asciidict.cpp
+ ${IFACE}/asyncimageio.cpp ${IFACE}/big5codec.cpp ${IFACE}/bitarray.cpp ${IFACE}/bitmap.cpp ${IFACE}/brush.cpp
+ ${IFACE}/buffer.cpp ${IFACE}/cache.cpp ${IFACE}/cleanuphandler.cpp ${IFACE}/color.cpp ${IFACE}/compactstyle.cpp
+ ${IFACE}/connection.cpp ${IFACE}/cstring.cpp ${IFACE}/cursor.cpp ${IFACE}/datastream.cpp ${IFACE}/datetime.cpp
+ ${IFACE}/deepcopy.cpp ${IFACE}/dict.cpp ${IFACE}/dir.cpp ${IFACE}/dom.cpp ${IFACE}/drawutil.cpp ${IFACE}/dropsite.cpp
+ ${IFACE}/editorfactory.cpp ${IFACE}/eucjpcodec.cpp ${IFACE}/euckrcodec.cpp ${IFACE}/event.cpp ${IFACE}/file.cpp
+ ${IFACE}/fileinfo.cpp ${IFACE}/focusdata.cpp ${IFACE}/fontdatabase.cpp ${IFACE}/font.cpp ${IFACE}/fontinfo.cpp
+ ${IFACE}/fontmetrics.cpp ${IFACE}/garray.cpp ${IFACE}/gb18030codec.cpp ${IFACE}/gcache.cpp ${IFACE}/gdict.cpp
+ ${IFACE}/glcolormap.cpp ${IFACE}/glist.cpp ${IFACE}/gvector.cpp ${IFACE}/hostaddress.cpp ${IFACE}/iconset.cpp
+ ${IFACE}/image.cpp ${IFACE}/intcache.cpp ${IFACE}/intdict.cpp ${IFACE}/interlacestyle.cpp ${IFACE}/iodevice.cpp
+ ${IFACE}/jiscodec.h ${IFACE}/jpunicode.cpp ${IFACE}/keysequence.cpp ${IFACE}/library.cpp ${IFACE}/locale.cpp
+ ${IFACE}/map.cpp ${IFACE}/memarray.cpp ${IFACE}/menudata.cpp ${IFACE}/metaobject.cpp ${IFACE}/mime.cpp ${IFACE}/movie.cpp
+ ${IFACE}/mutex.cpp ${IFACE}/namespace.cpp ${IFACE}/objectdict.cpp ${IFACE}/objectlist.cpp ${IFACE}/paintdevice.cpp
+ ${IFACE}/paintdevicemetrics.cpp ${IFACE}/painter.cpp ${IFACE}/pair.cpp ${IFACE}/palette.cpp ${IFACE}/pen.cpp
+ ${IFACE}/picture.cpp ${IFACE}/pixmapcache.cpp ${IFACE}/pixmap.cpp ${IFACE}/pngio.cpp ${IFACE}/pointarray.cpp
+ ${IFACE}/point.cpp ${IFACE}/polygonscanner.cpp ${IFACE}/printer.cpp ${IFACE}/ptrcollection.cpp
+ ${IFACE}/ptrdict.cpp ${IFACE}/ptrlist.cpp ${IFACE}/ptrqueue.cpp ${IFACE}/ptrstack.cpp ${IFACE}/ptrvector.cpp
+ ${IFACE}/rect.cpp ${IFACE}/regexp.cpp ${IFACE}/region.cpp ${IFACE}/rtlcodec.cpp ${IFACE}/semaphore.cpp
+ ${IFACE}/settings.cpp ${IFACE}/shared.cpp ${IFACE}/signalslotimp.cpp ${IFACE}/simplerichtext.cpp ${IFACE}/size.cpp
+ ${IFACE}/sizepolicy.cpp ${IFACE}/sjiscodec.cpp ${IFACE}/socketdevice.cpp ${IFACE}/sortedlist.cpp
+ ${IFACE}/sqlcursor.cpp ${IFACE}/sqleditorfactory.cpp ${IFACE}/sqlerror.cpp ${IFACE}/sqlfield.cpp
+ ${IFACE}/sql.cpp ${IFACE}/sqlindex.cpp ${IFACE}/sqlpropertymap.cpp ${IFACE}/sqlrecord.cpp ${IFACE}/sqlresult.cpp
+ ${IFACE}/sqlselectcursor.cpp ${IFACE}/string.cpp ${IFACE}/stringlist.cpp ${IFACE}/strlist.cpp ${IFACE}/strvec.cpp
+ ${IFACE}/stylefactory.cpp ${IFACE}/syntaxhighlighter.cpp ${IFACE}/textcodecfactory.cpp
+ ${IFACE}/textcodec.cpp ${IFACE}/textstream.cpp ${IFACE}/thread.cpp ${IFACE}/threadstorage.cpp
+ ${IFACE}/tl.cpp ${IFACE}/tsciicodec.cpp ${IFACE}/url.cpp ${IFACE}/urlinfo.cpp ${IFACE}/utfcodec.cpp ${IFACE}/uuid.cpp
+ ${IFACE}/valuelist.cpp ${IFACE}/valuestack.cpp ${IFACE}/valuevector.cpp ${IFACE}/variant.cpp ${IFACE}/vfbhdr.cpp
+ ${IFACE}/waitcondition.cpp ${IFACE}/whatsthis.cpp ${IFACE}/widgetfactory.cpp ${IFACE}/widgetintdict.cpp
+ ${IFACE}/widgetlist.cpp ${IFACE}/wmatrix.cpp ${IFACE}/xml.cpp ${IFACE}/private/tqucomextra_p.cpp
+ ${IFACE}/listiterator.cpp
VERSION 4.2.0
LINK ${QT_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}