summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b647309..7b948ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,12 @@ option( WITH_ALL_OPTIONS "Enable all optional support" OFF
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
##### configure checks
include( ConfigureChecks.cmake )
@@ -64,7 +70,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( client )
add_subdirectory( themes )
+
+##### other data
+
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
+
##### write configure files
configure_file( config.h.cmake config.h @ONLY )
-