summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2023-10-17 19:57:10 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2023-10-17 19:57:10 +0900
commit0eec68a32197fcf878eabe4434badcf73e2d4741 (patch)
tree6b468db129339c1a6c67222507291dc16199b67c /Makefile.am
downloadtwin-style-fahrenheit-0eec68a32197fcf878eabe4434badcf73e2d4741.tar.gz
twin-style-fahrenheit-0eec68a32197fcf878eabe4434badcf73e2d4741.zip
Initial code import from https://www.trinity-look.org/p/1100374. As per note on the website, the code has been abandoned. There is no license file in the source code, but given the package was available on the KDE3 store back in the days, it is reasonable to assume it was distributed under GPL2 license
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..13b33bd
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,20 @@
+SUBDIRS = $(TOPSUBDIRS)
+
+MAINTAINERCLEANFILES = subdirs configure.in acinclude.m4 configure.files
+
+EXTRA_DIST = Makefile.cvs admin
+
+AUTOMAKE_OPTIONS = foreign
+
+$(top_srcdir)/configure.in: configure.in.in $(top_srcdir)/subdirs
+ cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common configure.in ;
+
+$(top_srcdir)/subdirs:
+ cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common subdirs
+
+$(top_srcdir)/acinclude.m4: $(top_srcdir)/admin/acinclude.m4.in $(top_srcdir)/admin/libtool.m4.in
+ @cd $(top_srcdir) && cat admin/acinclude.m4.in admin/libtool.m4.in > acinclude.m4
+
+dist-hook:
+ cd $(top_distdir) && perl admin/am_edit -padmin
+ cd $(top_distdir) && $(MAKE) -f admin/Makefile.common subdirs