summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorjsorg71 <jsorg71>2006-03-04 00:34:12 +0000
committerjsorg71 <jsorg71>2006-03-04 00:34:12 +0000
commit42a6b2bdd0c4bf89989b45187b0c11bc95455ffd (patch)
tree5faae86fed3b3f36e044d2e8d3a3ec6e9f160bd9 /debian
parentd7e7beae5ee6d974ae21ef7c2e0058c29de37b79 (diff)
downloadxrdp-proprietary-42a6b2bdd0c4bf89989b45187b0c11bc95455ffd.tar.gz
xrdp-proprietary-42a6b2bdd0c4bf89989b45187b0c11bc95455ffd.zip
add debian directory
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/compat1
-rw-r--r--debian/control13
-rw-r--r--debian/copyright25
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs0
-rw-r--r--debian/postinst2
-rw-r--r--debian/postrm2
-rw-r--r--debian/preinst4
-rw-r--r--debian/prerm4
-rw-r--r--debian/rules98
11 files changed, 160 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000..9c8c90a0
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,9 @@
+xrdp (0.2) unstable; urgency=low
+
+ * Initial Release.
+
+ -- Jay Sorg <jay.sorg@gmail.com> Sat, 18 Feb 2006 13:58:29 -0600
+
+Local variables:
+mode: debian-changelog
+End:
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..b8626c4c
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..37d70ac7
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,13 @@
+Source: xrdp
+Section: net
+Priority: optional
+Maintainer: Jay Sorg <jay.sorg@gmail.com>
+Build-Depends: debhelper (>= 4.0.0)
+Standards-Version: 3.6.0
+
+Package: xrdp
+Architecture: i386
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: <An open source remote desktop protocol(rdp) server.>
+ Based on the work of rdesktop, xrdp uses the remote desktop
+ protocol to present a GUI to the user.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 00000000..9add4f02
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,25 @@
+This is xrdp, written and maintained by Jay Sorg <jay.sorg@gmail.com>
+on Sat, 18 Feb 2006 13:58:29 -0600.
+
+The original source can always be found at:
+ ftp://ftp.debian.org/dists/unstable/main/source/
+
+Copyright (C) 2003 Jay Sorg
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+ 02111-1307, USA.
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 00000000..d91aa8ee
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/xrdp
+etc/xrdp
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/debian/docs
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 00000000..7a4a5b78
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,2 @@
+#!/bin/sh
+update-rc.d xrdp_control.sh defaults > /dev/null
diff --git a/debian/postrm b/debian/postrm
new file mode 100644
index 00000000..deca14b0
--- /dev/null
+++ b/debian/postrm
@@ -0,0 +1,2 @@
+#!/bin/sh
+update-rc.d -f xrdp_control.sh remove > /dev/null
diff --git a/debian/preinst b/debian/preinst
new file mode 100644
index 00000000..75d17b14
--- /dev/null
+++ b/debian/preinst
@@ -0,0 +1,4 @@
+#!/bin/sh
+if [ -e /usr/xrdp/xrdp ]; then
+ /etc/init.d/xrdp_control.sh stop
+fi
diff --git a/debian/prerm b/debian/prerm
new file mode 100644
index 00000000..75d17b14
--- /dev/null
+++ b/debian/prerm
@@ -0,0 +1,4 @@
+#!/bin/sh
+if [ -e /usr/xrdp/xrdp ]; then
+ /etc/init.d/xrdp_control.sh stop
+fi
diff --git a/debian/rules b/debian/rules
new file mode 100644
index 00000000..3f1e32a3
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,98 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+ #/usr/bin/docbook-to-man debian/xrdp.sgml > xrdp.1
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/xrdp.
+ $(MAKE) installdeb DESTDIRDEB=$(CURDIR)/debian/xrdp
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure