summaryrefslogtreecommitdiffstats
path: root/sesman/chansrv/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-08-20 00:29:09 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-08-20 00:29:09 -0500
commit57029de2707808c3e7d12568af3de87eaca71828 (patch)
tree0dd7aca471ffddede7d6ec8d54d075e515a9ca9e /sesman/chansrv/Makefile.am
parentb62256d54dd71705a29da49bc8ee62d6ebd95230 (diff)
parentc5862f367ca68763dd3070598a36ea82db7f3566 (diff)
downloadxrdp-proprietary-57029de2707808c3e7d12568af3de87eaca71828.tar.gz
xrdp-proprietary-57029de2707808c3e7d12568af3de87eaca71828.zip
Merge remote-tracking branch 'origin/master'
Diffstat (limited to 'sesman/chansrv/Makefile.am')
-rw-r--r--sesman/chansrv/Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/sesman/chansrv/Makefile.am b/sesman/chansrv/Makefile.am
index 486d49a8..9d52d950 100644
--- a/sesman/chansrv/Makefile.am
+++ b/sesman/chansrv/Makefile.am
@@ -1,10 +1,21 @@
EXTRA_DIST = chansrv.h clipboard.h devredir.h sound.h
+EXTRA_DEFINES =
+EXTRA_INCLUDES =
+EXTRA_LIBS =
+EXTRA_FLAGS =
+
+if XRDP_SIMPLESOUND
+EXTRA_DEFINES += -DXRDP_SIMPLESOUND
+EXTRA_LIBS += -lpthread -lpulse -lpulse-simple
+endif
+
AM_CFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \
-DXRDP_SHARE_PATH=\"${datadir}/xrdp\" \
- -DXRDP_PID_PATH=\"${localstatedir}/run\"
+ -DXRDP_PID_PATH=\"${localstatedir}/run\" \
+ $(EXTRA_DEFINES)
INCLUDES = \
-I$(top_srcdir)/common \
@@ -17,7 +28,12 @@ xrdp_chansrv_SOURCES = \
chansrv.c \
sound.c \
clipboard.c \
- devredir.c
+ devredir.c \
+ rail.c \
+ xcommon.c
+
+xrdp_chansrv_LDFLAGS = \
+ $(EXTRA_FLAGS)
xrdp_chansrv_LDADD = \
-L/usr/X11R6/lib \