summaryrefslogtreecommitdiffstats
path: root/genkeymap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'genkeymap/Makefile.am')
-rw-r--r--genkeymap/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/genkeymap/Makefile.am b/genkeymap/Makefile.am
index aed72512..25767395 100644
--- a/genkeymap/Makefile.am
+++ b/genkeymap/Makefile.am
@@ -1,9 +1,12 @@
+AM_CFLAGS = $(X_CFLAGS)
bin_PROGRAMS = \
xrdp-genkeymap
xrdp_genkeymap_SOURCES = genkeymap.c evdev-map.c
+xrdp_genkeymap_LDFLAGS = \
+ $(X_LIBS)
+
xrdp_genkeymap_LDADD = \
- -L/usr/X11R6/lib \
- -lX11
+ $(X_PRE_LIBS) -lX11 $(X_EXTRA_LIBS)