summaryrefslogtreecommitdiffstats
path: root/libxrdp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libxrdp/Makefile.am')
-rw-r--r--libxrdp/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/libxrdp/Makefile.am b/libxrdp/Makefile.am
new file mode 100644
index 00000000..96ec7cd2
--- /dev/null
+++ b/libxrdp/Makefile.am
@@ -0,0 +1,24 @@
+INCLUDES = \
+ -I$(top_srcdir)/common \
+ -DXRDP_CFG_FILE=\"/etc/xrdp/xrdp.ini\" \
+ -DXRDP_KEY_FILE=\"/etc/xrdp/rsakeys.ini\"
+
+lib_LTLIBRARIES = \
+ libxrdp.la
+
+libxrdp_la_SOURCES = \
+ libxrdp.c \
+ xrdp_channel.c \
+ xrdp_iso.c \
+ xrdp_mcs.c \
+ xrdp_orders.c \
+ xrdp_rdp.c \
+ xrdp_sec.c \
+ xrdp_tcp.c \
+ xrdp_bitmap_compress.c
+
+libxrdp_la_LIBADD = \
+ $(top_srcdir)/common/libxrdp-common.a
+
+libxrdp_la_LDFLAGS = \
+ -version-info 5:0:5