summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-26 17:31:07 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-26 17:31:17 +0200
commitf4ab375232c6a959f4facc9c15c4d4aa7622d3c4 (patch)
tree28ad925c84b5d9867f08dc5e712abbf763a04ab6 /CMakeLists.txt
parent71fba7a27991a6d031bc4057b6354581a0d05b6a (diff)
downloadyakuake-f4ab375232c6a959f4facc9c15c4d4aa7622d3c4.tar.gz
yakuake-f4ab375232c6a959f4facc9c15c4d4aa7622d3c4.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 65d3fb557cc78ad81fc1e411f8f37038fbc0b89e)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d1dc799..6de1bbd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,10 +68,13 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( yakuake )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
##### write configure files