summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2024-01-02 21:28:33 +0300
committerAlexander Golubev <fatzer2@gmail.com>2024-01-02 21:28:33 +0300
commit0a1929653f902ec3418f950ad066723101f0bf06 (patch)
treea304d5e3b0fb1cfd2e21edf95794d7c01fb10b46 /CMakeLists.txt
parent0ce4b8104de6f95c7c5d76c06a1ce0e6386de50b (diff)
downloadakode-0a1929653f902ec3418f950ad066723101f0bf06.tar.gz
akode-0a1929653f902ec3418f950ad066723101f0bf06.zip
cmake: make flac, speex and vorbis support in xiph optional
Signed-off-by: Alexander Golubev <fatzer2@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 14 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 715bba0..84be212 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,17 +51,20 @@ tde_setup_paths( )
option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_LIBLTDL "Build with libltdl" OFF )
-OPTION( WITH_ALSA_SINK "Build with alsa sink" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_JACK_SINK "Build with jack sink" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_PULSE_SINK "Build with pulseaudio sink" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_OSS_SINK "Build with oss sink" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_SUN_SINK "Build with sun sink" OFF )
-OPTION( WITH_FFMPEG_DECODER "Build with ffmpeg decoder" OFF )
-option( WITH_MPC_DECODER "Build with mpc decoder" ${WITH_ALL_OPTIONS} )
-option( WITH_MPEG_DECODER "Build with mpeg decoder" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_SRC_RESAMPLER "Build with src resampler" ${WITH_ALL_OPTIONS} )
-option( WITH_XIPH_DECODER "Build with xiph decoder" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_LIBLTDL "Build with libltdl" OFF )
+OPTION( WITH_ALSA_SINK "Build with alsa sink" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_JACK_SINK "Build with jack sink" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_PULSE_SINK "Build with pulseaudio sink" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_OSS_SINK "Build with oss sink" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_SUN_SINK "Build with sun sink" OFF )
+OPTION( WITH_FFMPEG_DECODER "Build with ffmpeg decoder" OFF )
+option( WITH_MPC_DECODER "Build with musepack decoder" ${WITH_ALL_OPTIONS} )
+option( WITH_MPEG_DECODER "Build with mpeg decoder" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_SRC_RESAMPLER "Build with src resampler" ${WITH_ALL_OPTIONS} )
+option( WITH_XIPH_DECODER "Build with xiph decoder" ${WITH_ALL_OPTIONS} )
+option( WITH_XIPH_FLAC "Build xiph decoder with flac support" ON )
+option( WITH_XIPH_SPEEX "Build xiph decoder with speex support" ON )
+option( WITH_XIPH_VORBIS "Build xiph decoder with vorbis support" ON )
##### configure checks