summaryrefslogtreecommitdiffstats
path: root/mcop_mt/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-10-06 15:27:35 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-10-06 15:27:35 +0000
commit4388c9f844be237080c30661997d5d56b2aecb5a (patch)
tree4a3f01ae3b8cebb7647bc7f050f8c4a2f57c633f /mcop_mt/CMakeLists.txt
parent435ac45427c2ab7517ed2d1deeed2be983679131 (diff)
downloadarts-4388c9f844be237080c30661997d5d56b2aecb5a.tar.gz
arts-4388c9f844be237080c30661997d5d56b2aecb5a.zip
[dependencies/arts] restyle and migrate to tde_ macrossoundserver/CMakeLists.txt
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/dependencies/arts@1183226 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'mcop_mt/CMakeLists.txt')
-rw-r--r--mcop_mt/CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/mcop_mt/CMakeLists.txt b/mcop_mt/CMakeLists.txt
index 09fed8c..d3cd471 100644
--- a/mcop_mt/CMakeLists.txt
+++ b/mcop_mt/CMakeLists.txt
@@ -9,10 +9,16 @@
#
#################################################
-set( mcop_mt_SRCS
- threads_posix.cc
+include_directories(
+ ${CMAKE_BINARY_DIR}
)
-add_library( mcop_mt SHARED ${mcop_mt_SRCS} )
-set_target_properties( mcop_mt PROPERTIES VERSION 1.0 SOVERSION 1 )
-target_link_libraries( mcop_mt mcop artsflow )
+
+##### mcop_mt (shared lib ) #####################
+
+tde_add_library( mcop_mt SHARED
+ SOURCES threads_posix.cc
+ VERSION 1.0.0
+ LINK artsflow-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)