summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-01-29 21:07:35 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-01-29 21:07:35 +0100
commite05788fc201a831ddb782ba48aa530c059f1646f (patch)
tree1346350b49515702815f8114d3271832d4b9c0ea /CMakeLists.txt
parent8f3cb3417e6fa940bab6e3aa8cdda24bc3be7659 (diff)
downloadavahi-tqt-e05788fc201a831ddb782ba48aa530c059f1646f.tar.gz
avahi-tqt-e05788fc201a831ddb782ba48aa530c059f1646f.zip
Update CMake rules
+ Add WITH_GCC_VISIBILITY option + Use common tde_setup_gcc_visibility + Add TestBigEndian and tde_setup_largefiles Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 21 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d2e5745..d77d4e9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,7 @@ set( PACKAGE_VERSION 0.6.30 )
##### include essential cmake modules ###########
+include( CheckSymbolExists )
include( FindPkgConfig )
@@ -28,7 +29,6 @@ include( FindPkgConfig )
set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
include( TDEMacros )
-tde_setup_architecture_flags( )
##### setup install paths #######################
@@ -37,6 +37,22 @@ include( TDESetupPaths )
tde_setup_paths( )
+##### optional stuff
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+
+
+##### setup architecture flags ##################
+
+tde_setup_architecture_flags( )
+
+include(TestBigEndian)
+test_big_endian(WORDS_BIGENDIAN)
+
+tde_setup_largefiles( )
+
+
##### configure checks ##########################
find_package( TQt )
@@ -53,10 +69,10 @@ if( NOT AVAHI_COMMON )
endif( )
message( STATUS " found ${AVAHI_COMMON}" )
-if( UNIX )
- set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility=hidden" )
- add_definitions( -DHAVE_VISIBILITY_HIDDEN )
-endif( UNIX )
+if( WITH_GCC_VISIBILITY )
+ tde_setup_gcc_visibility( )
+ add_definitions( -D__KDE_HAVE_GCC_VISIBILITY )
+endif( )
#### pkg-config #################################