summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..242b69e
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,53 @@
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+ACLOCAL_AMFLAGS = -I common
+
+include $(srcdir)/common/doxygen.mk
+
+EXTRA_DIST = \
+ autogen.sh \
+ bootstrap.sh \
+ LICENSE \
+ avahi-tqt.pc.in \
+ common/introspection.m4
+
+SUBDIRS = \
+ avahi-tqt
+
+DX_EXAMPLE_PATH = $(srcdir)/examples
+DX_EXAMPLE_PATTERNS = *.c
+
+DX_INPUT = \
+ $(srcdir)/avahi-tqt/qt-watch.h
+
+
+pkgconfigdir = $(libdir)/pkgconfig
+
+%.pc: %.pc.in
+ $(AM_V_GEN)sed -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@libdir\@,$(libdir),g' \
+ -e 's,@HOWL_COMPAT_VERSION\@,$(HOWL_COMPAT_VERSION),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
+
+pkgconfig_DATA = avahi-tqt.pc
+CLEANFILES = avahi-tqt.pc
+
+DISTCHECK_CONFIGURE_FLAGS = \
+ --disable-monodoc \
+ --enable-introspection \
+ --with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)