summaryrefslogtreecommitdiffstats
path: root/src/imageplugins/perspective/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-12-01 10:36:36 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-12-26 10:37:38 +0900
commit76a8e935be38afad0105c46d5a2aa7b58162223b (patch)
treeec4150730a6bb1900c9d4541fd9faf0c4d41b00a /src/imageplugins/perspective/CMakeLists.txt
parent67fd8bef19878c6940d48fbdafe07a8842c99fd1 (diff)
downloaddigikam-76a8e935be38afad0105c46d5a2aa7b58162223b.tar.gz
digikam-76a8e935be38afad0105c46d5a2aa7b58162223b.zip
Conversion to cmake building system
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'src/imageplugins/perspective/CMakeLists.txt')
-rw-r--r--src/imageplugins/perspective/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/imageplugins/perspective/CMakeLists.txt b/src/imageplugins/perspective/CMakeLists.txt
new file mode 100644
index 00000000..92e11cb2
--- /dev/null
+++ b/src/imageplugins/perspective/CMakeLists.txt
@@ -0,0 +1,27 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+
+##### digikamimageplugin_perspective (kpart)
+
+tde_add_kpart( digikamimageplugin_perspective AUTOMOC
+ SOURCES
+ imageplugin_perspective.cpp perspectivetool.cpp perspectivewidget.cpp triangle.cpp matrix.cpp
+ LINK dimgfilters-static digikam-shared tdecore-shared tdeutils-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other files
+
+install(
+ FILES digikamimageplugin_perspective_ui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
+)
+
+tde_create_translated_desktop(
+ SOURCE digikamimageplugin_perspective.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)