summaryrefslogtreecommitdiffstats
path: root/src/libs/greycstoration/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-12-01 10:36:36 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-12-26 10:37:38 +0900
commit76a8e935be38afad0105c46d5a2aa7b58162223b (patch)
treeec4150730a6bb1900c9d4541fd9faf0c4d41b00a /src/libs/greycstoration/CMakeLists.txt
parent67fd8bef19878c6940d48fbdafe07a8842c99fd1 (diff)
downloaddigikam-76a8e935be38afad0105c46d5a2aa7b58162223b.tar.gz
digikam-76a8e935be38afad0105c46d5a2aa7b58162223b.zip
Conversion to cmake building system
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'src/libs/greycstoration/CMakeLists.txt')
-rw-r--r--src/libs/greycstoration/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/libs/greycstoration/CMakeLists.txt b/src/libs/greycstoration/CMakeLists.txt
new file mode 100644
index 00000000..528a0259
--- /dev/null
+++ b/src/libs/greycstoration/CMakeLists.txt
@@ -0,0 +1,20 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/src/libs/dimg/filters
+)
+
+
+##### greycstoration library (static)
+
+tde_add_library( greycstoration STATIC_PIC AUTOMOC
+ SOURCES greycstorationiface.cpp greycstorationwidget.cpp
+ LINK dimgfilters-static histogram-static tdecore-shared ${CMAKE_THREAD_LIBS_INIT}
+)
+
+
+##### other files
+
+install(
+ FILES greycstorationiface.h greycstorationwidget.h greycstorationsettings.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/${PROJECT_NAME}
+)