summaryrefslogtreecommitdiffstats
path: root/src/libs/levels/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-12-01 10:36:36 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-12-26 10:37:38 +0900
commit76a8e935be38afad0105c46d5a2aa7b58162223b (patch)
treeec4150730a6bb1900c9d4541fd9faf0c4d41b00a /src/libs/levels/CMakeLists.txt
parent67fd8bef19878c6940d48fbdafe07a8842c99fd1 (diff)
downloaddigikam-76a8e935be38afad0105c46d5a2aa7b58162223b.tar.gz
digikam-76a8e935be38afad0105c46d5a2aa7b58162223b.zip
Conversion to cmake building system
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'src/libs/levels/CMakeLists.txt')
-rw-r--r--src/libs/levels/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/libs/levels/CMakeLists.txt b/src/libs/levels/CMakeLists.txt
new file mode 100644
index 00000000..6d809574
--- /dev/null
+++ b/src/libs/levels/CMakeLists.txt
@@ -0,0 +1,14 @@
+##### levels library (static)
+
+tde_add_library( levels STATIC_PIC
+ SOURCES imagelevels.cpp
+ LINK histogram-static tdecore-shared
+)
+
+
+##### other files
+
+install(
+ FILES imagelevels.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/${PROJECT_NAME}
+)