summaryrefslogtreecommitdiffstats
path: root/digikam/libs/lprof/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'digikam/libs/lprof/Makefile.am')
-rw-r--r--digikam/libs/lprof/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/digikam/libs/lprof/Makefile.am b/digikam/libs/lprof/Makefile.am
new file mode 100644
index 00000000..d1043b5e
--- /dev/null
+++ b/digikam/libs/lprof/Makefile.am
@@ -0,0 +1,13 @@
+# Gilles Caulier 12/01/06: lprof implementation is in C not C++ and do not
+# support 'nofinal' compilation option.
+KDE_OPTIONS = nofinal
+
+noinst_LTLIBRARIES = liblprof.la
+
+noinst_HEADERS = lcmsprf.h
+
+liblprof_la_CXXFLAGS = -w -fomit-frame-pointer
+
+liblprof_la_SOURCES = cmshull.cpp cmslm.cpp cmslnr.cpp cmsmatn.cpp \
+ cmsmkmsh.cpp cmsmntr.cpp cmsoutl.cpp cmspcoll.cpp \
+ cmsprf.cpp cmsreg.cpp cmsscn.cpp cmssheet.cpp