summaryrefslogtreecommitdiffstats
path: root/debian/htdig/htdig-3.2.0b6/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-11-05 13:28:23 +0100
committerSlávek Banko <slavek.banko@axis.cz>2021-11-05 13:28:23 +0100
commit8c787c3591c1c885b91a54128835b400858c5cca (patch)
treeeca1b776912a305c4d45b3964038278a2fae1ead /debian/htdig/htdig-3.2.0b6/Makefile.am
parentfe188b907cdf30dfdfe0eba9412e7f8749fec158 (diff)
downloadextra-dependencies-8c787c3591c1c885b91a54128835b400858c5cca.tar.gz
extra-dependencies-8c787c3591c1c885b91a54128835b400858c5cca.zip
DEB htdig: Added to repository.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/htdig/htdig-3.2.0b6/Makefile.am')
-rw-r--r--debian/htdig/htdig-3.2.0b6/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/debian/htdig/htdig-3.2.0b6/Makefile.am b/debian/htdig/htdig-3.2.0b6/Makefile.am
new file mode 100644
index 00000000..8dca1481
--- /dev/null
+++ b/debian/htdig/htdig-3.2.0b6/Makefile.am
@@ -0,0 +1,36 @@
+# Main Makefile for ht://Dig
+# Copyright (c) 1995-2004 The ht://Dig Group
+# For copyright details, see the file COPYING in your distribution
+# or the GNU Library General Public License version 2 or later
+# <http://www.gnu.org/copyleft/lgpl.html>
+
+include $(top_srcdir)/Makefile.config
+
+if TESTS
+TESTDIR = test
+endif
+
+SUBDIRS = db htlib htword htcommon htnet htfuzzy htdb htdig htsearch httools installdir include htdoc $(TESTDIR)
+
+EXTRA_DIST = .version Makefile.config ChangeLog.0 contrib
+
+dist-hook:
+ find $(distdir) -depth -name CVS -print | xargs rm -fr
+
+#
+# If --enable-tests is not specified, should remove
+# the test/Makefile anyway
+#
+distclean-local:
+ if test "X$(TESTDIR)" = "Xtest" ; \
+ then \
+ rm -f test/Makefile test/test_functions ; \
+ fi
+
+install-data-hook:
+ @echo ""
+ @echo "Installation done."
+ @echo ""
+ @echo "Before you can start searching, you will need to create a"
+ @echo "search database. A sample script to do this has been"
+ @echo "installed as " $(DESTDIR)$(bindir)/rundig