summaryrefslogtreecommitdiffstats
path: root/debian/uncrustify-trinity/uncrustify-trinity-0.72.0/emscripten/README.md
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-05-19 16:22:10 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-05-19 19:14:52 +0900
commit71fb4a139179e9d27070f7f3e98971e3e029697f (patch)
tree92fbf03f1e546b3c99e6e06e98100b6ef8e4e2c6 /debian/uncrustify-trinity/uncrustify-trinity-0.72.0/emscripten/README.md
parent6eae1a16a1001287ef5129db86f4ef2145ace3ca (diff)
downloadextra-dependencies-71fb4a139179e9d27070f7f3e98971e3e029697f.tar.gz
extra-dependencies-71fb4a139179e9d27070f7f3e98971e3e029697f.zip
uncrustify: updated to version 0.73
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'debian/uncrustify-trinity/uncrustify-trinity-0.72.0/emscripten/README.md')
-rw-r--r--debian/uncrustify-trinity/uncrustify-trinity-0.72.0/emscripten/README.md42
1 files changed, 0 insertions, 42 deletions
diff --git a/debian/uncrustify-trinity/uncrustify-trinity-0.72.0/emscripten/README.md b/debian/uncrustify-trinity/uncrustify-trinity-0.72.0/emscripten/README.md
deleted file mode 100644
index 22012383..00000000
--- a/debian/uncrustify-trinity/uncrustify-trinity-0.72.0/emscripten/README.md
+++ /dev/null
@@ -1,42 +0,0 @@
-building
---------------------------------------------------------------------------------
- **dependencies**: cmake, python, clang, emscripten, node
-
- 1. create a `build` directory somewhere
- 2. inside this directory call `cmake <CMakeLists.txt directory>` and `make`<br>
- (the CMakeLists.txt file is located in <uncrustify_root_dir>/emscripten)
-
-Optionally the generated libUncrustify.js can be tested via `make emscripten_test`
-
-_libUncrustify.js_ example usage
---------------------------------------------------------------------------------
-1. load module instance:
- ```js
- var uncrustify = libUncrustify();
- ```
-
-2. set option settings either one at a time with:
- ```js
- uncrustify.set_option( "optionNameString", "newOptionValueString" );
- ```
-
- or a whole bunch via:
-
- ```js
- uncrustify.loadConfig( "configFileFormatString" )
- ```
-
-3. set the language of the to be formated file string
- ```js
- uncrustify.set_language( languageInt );
- ```
-
-4. format a file string:
- ```js
- var uncrustyFileString = uncrustify.uncrustify( "crustyFileString" );
- ```
-
-5. delete initialized module instance:
- ```js
- uncrustify.destruct();
- ```