summaryrefslogtreecommitdiffstats
path: root/debian/htdig/htdig-3.2.0b6/htcommon/Makefile.win32
diff options
context:
space:
mode:
Diffstat (limited to 'debian/htdig/htdig-3.2.0b6/htcommon/Makefile.win32')
-rw-r--r--debian/htdig/htdig-3.2.0b6/htcommon/Makefile.win3225
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/htdig/htdig-3.2.0b6/htcommon/Makefile.win32 b/debian/htdig/htdig-3.2.0b6/htcommon/Makefile.win32
new file mode 100644
index 00000000..62aef30c
--- /dev/null
+++ b/debian/htdig/htdig-3.2.0b6/htcommon/Makefile.win32
@@ -0,0 +1,25 @@
+
+TARGET = $(LIBDIR)/libcommon$(LIBSFX)
+
+# ----------------------------------------------------------------------------
+# add new library members to this list
+
+# ----------------------------------------------------------------------------
+
+include ../Makedefs.win32
+
+CXXSRC = DocumentDB.cc DocumentRef.cc HtWordReference.cc \
+ HtWordList.cc defaults.cc HtURLCodec.cc URL.cc URLTrans.cc \
+ HtZlibCodec.cc cgi.cc HtSGMLCodec.cc HtConfiguration.cc \
+ HtURLRewriter.cc
+
+LXXSRC = conf_lexer.lxx
+YXXSRC = conf_parser.yxx
+
+CPPFLAGS += -DYY_NEVER_INTERACTIVE -DHAVE_CONFIG_H -I../db -I../htlib -I../htword
+
+$(TARGET): $(OBJDIRDEP) $(LIBDIRDEP) $(OBJS)
+ $(AR) $(ARFLAGS) $(OBJS)
+
+include ../Makerules.win32
+