summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFabio Rossi <rossi.f@inwind.it>2018-12-17 17:07:37 +0100
committerMichele Calgaro <michele.calgaro@yahoo.it>2018-12-18 23:41:51 +0900
commit169d30ec92e54e9454d777e45b943ae161f7d830 (patch)
tree286ae43c2087659daaaa98c5b4d13fff5ce7c70d /CMakeLists.txt
parent09f5e97f2cff7e7e5abdb130fc03671c37328a3f (diff)
downloadfilelight-169d30ec92e54e9454d777e45b943ae161f7d830.tar.gz
filelight-169d30ec92e54e9454d777e45b943ae161f7d830.zip
Avoid overriding user linker flags (LDFLAGS) for modules and shared libs
Signed-off-by: Fabio Rossi <rossi.f@inwind.it> (cherry picked from commit 4702db0e8bd645a41f448f14f3592ae57ab70112)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fd15045..dd2a637 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,8 +67,8 @@ add_definitions(
)
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
-set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )
-set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
+set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )
##### filelight directories #####################